Jetpack Issues - Questions

Hello! I would like to ask a question about Jetpack.

I’m wondering about Jetpack Installing steps. Because everytime, I got issues. For example; I install the jetpack, the installation finishes but when I tried to

sudo apt-get update

there are a lots of problems on Ubuntu. I solve the problem however, everytime happen something like error or problem. Is it because of the Jetpack? What should I do? I don’t have a router, have a modem. Would be it a problem?

Another exmaple is that I had to install ROS. I installed but there are lots of problems again. Sometime I can’t open the usb camera, I don’t why there are no logs about that.

Hi mustafamertunali, what errors are you experiencing?

Is the networking connection between your Jetson and PC wireless, or ethernet? If you connect the Jetson and PC via WiFi during the JetPack setup, you can get weird errors. The connection between Jetson and PC should be hard ethernet, typically via a switch or router or wired directly to a spare NIC port on the PC. Modem may be fine too, depending on what LAN capabilities it has. If you suspect problems with the modem, try using a second Ethernet port on the PC (using a USB dongle to add RJ45 should be fine). If you are using the second port method, the PC would need a connection to the Internet on the first port or WiFi, to download the JetPack packages before they are flashed to the Jetson.

The networking connection is between my Jetson and PC ethernet. Sometime I don’t have a problem. It is very interesting for me. Is there a different way to install Jetpack?

By the way, I solved the problems reinstalling Jetpack. Now, I got no error. :D