Jetpack L4T does not match the Driver Package L4T

I downloaded the driver package (Tegra210_Linux_R24.2.1_aarch64.tbz2) to automate the process of loading the TX1. I assumed the files would be the same as what the Jetpack provides, as far as Linux for Tegra is concerned and it’s tools. But after doing a diff of the files I find that they do not match. Nvidia, if you are going to provide tools please make sure that all your tools and files are released with the correct version and have the correct files. I spent a lot of time chasing a problem that could have been avoided. Another thing is don’t release files and change them without changing the version number, which happened a while back on Jetpack 2.1.1

Downloads Used:

http://developer.download.nvidia.com/embedded/L4T/r24_Release_v2.1/BSP/Tegra210_Linux_R24.2.1_aarch64.tbz2
https://developer.nvidia.com/embedded/dlc/jetpack-l4t-2_3_1

The sha1sum of http://developer.download.nvidia.com/embedded/L4T/r24_Release_v2.1/BSP/Tegra210_Linux_R24.2.1_aarch64.tbz2 file is 16967a684902755616d66ead9c94e718b633106e

The sha1sum of the driver package in JetPack 2.3.1 is the same.

Can you please let us know how you compared them?

I think he may be referring to the sample rootfs rather than the driver package.

No it wasn’t the rootfs although I made a mistake in my script that downloads the driver package. It was downloading 2.0 instead of 2.1. So false alarm, I was just upset, when I wrote the post because I failed to see the mistake then.

Thanks for the the quick reply.