Jetpack SDK dependencies

Is there a dependency of Jetpack SDK on particular l4t release or they are just aggregated together to form an officially supported distribution?

In particular, I am interested in using L4T 32.3.1, as well as host side flashing tools of JetPack 4.3, but I have to use the versions of cuda, cudnn and opencv corresponding to Jetpack 4.2 release. Would that be possible?

Is it possible to install e.g. opencv from ubuntu package repository?

Hi krikun.daniel,

Yes, each JetPack SDK has dependency with particular L4T release due to low layer driver, library and supported SDKs, it can not work if the corresponding versions are not right.

Please refer to JetPack Archive | NVIDIA Developer