JetPack SDK in Docker for simple and clean flashing of a Jetson TX2

Hi guys,

this is my first post so I do not know if this is the correct forum for this…

After I went almost crazy with flashing my Jetson TX2 Development Board I tried many things like creation of an VM for the JetPack SDK. Nothing worked (see many threads in this forum with VM issues) mostly due to USB controller issues. Let alone the fact that 3 of 4 computers are not capable at all to even flash the device natively. Somehow I installed the SDK on my host and directly broke my nvidia-container-runtime, CUDA and docker on my host :-(

That was the motivation for this guide. I have create a Dockerfile and accompanying scripts to completely put the SDK into an docker image so that no impact is made on the host and no sudo rights are required (I know docker use equals more or less root).

I have wrote an medium.com article as a guide and a github repo:


I figure maybe this can be useful for other people as well and hopefully avoid any frustration since the Jetson Platform is awesome but lacks sometimes from the SDK side.

Any input and feedback is welcome as well as issues. I have flashed with this container Jetson TX2 dev boards multiple times and also cloned the flash memory from within the container.

BR,
Bugra

Thanks for your sharing to community. Good job!