[JetPack3.3 & TX2] /bin/bash: ./flash.sh: No such file or directory

Hi,

I am having this problem during post installation step when TX2 is in recovery mode.
after getting the TX2 in recovery mode, I pressed “Enter” as the guidelines say. Also ‘lsusb’ command detects TX2 in recovery mode by showing “Nvidia Corp”.

I got the same error as in the following link and tried the solutions provided but nothing worked for my case.
https://devtalk.nvidia.com/default/topic/1000253/jetson-tx1/jetpack-not-able-to-load-on-tx1/1

Any help would be appreciated

What command did you run to get the error? Also, does the host PC have internet access without firewall or proxy?

Hi @linuxdev,

I just followed the steps shown for the post installation process. and after placing the TX2 in recovery mode, I just pressed “Enter”.
The Host PC doesn’t have firewall enabled or proxy and has internet access

The steps which occur for a combined flash and post install would be to put the TX2 in recovery mode, flash over the micro-B USB, and to then reboot the TX2 (automatic if flash occurred), and after the reboot to install extra packages over wired ethernet (in R32.x+ there is a virtual USB wired ethernet, but before this it was only the regular ethernet connector). Which release are you using? Did you choose to both flash and install software? If R32.1, after the flash did you log in locally to the TX2 and set up the login account before proceeding to the extra package install?

If you are doing only post install without flashing, then the TX2 must actually not be in recovery mode.

In all cases JetPack or SDK Manager must download a manifest, and then from this download yet more files. If networking to the outside world on the host PC fails, then you won’t have the ability to download the manifest itself, nor any of the other files.

@linuxdev , I am trying to flash over micro-B USB but that gave the error which i mentioned in question. I agree that after proper flashing and installation of JetPack, TX2 boots automatically. But flashing is giving error and also I flashing and installing the software both combined.

Did you run JetPack, SDK Manager, or command line flash? Does your host PC have internet access without proxy and firewall? Which release of JetPack/SDK Manager/command line flash?

@linuxdev,
I am running JetPack flash. JetPack3.3 L4T28.2.1 is being flashed. Yes, the host PC is having internet access without firewall.

What happens is that JetPack downloads a manifest file. From this it downloads several packages. One of those is the driver package. It is the driver package unpack which produces flash.sh within the “Linux_for_Tegra/” subdirectory. If you ran into a bug which caused a failure to download or a failure to unpack, then this would occur. There is currently a bzip2 bug in a recent Ubuntu update, and perhaps it was unpack which failed due to this (but logs were not posted so it is hard to say). If it is the bzip2 bug, then see:
https://devtalk.nvidia.com/default/topic/1056381/jetson-agx-xavier/jetpack-4-2-xavier-install-failed/

@linuxdev,
I installed JetPack4.2 and it’s running well as of now. Before installation via SDKmanager, I followed these steps mentioned by @brenozanchetta (in this post https://devtalk.nvidia.com/default/topic/1056381/jetson-agx-xavier/jetpack-4-2-xavier-install-failed/)

wget http://launchpadlibrarian.net/206950099/bzip2_1.0.6-8_amd64.deb wget http://launchpadlibrarian.net/206950098/libbz2-1.0_1.0.6-8_amd64.deb
sudo apt install bzip2_1.0.6-8_amd64.deb libbz2-1.0_1.0.6-8_amd64.deb sudo dpkg -i bzip2_1.0.6-8_amd64.deb libbz2-1.0_1.0.6-8_amd64.deb

I worked great. Thank you for your time and help @linuxdev, appreciate