Jetpack5.0.2 Xavier pcie endpoint mode [repetition]

Hi as i tried to descrieb here:

I have the same error as that poster, but a new topic was wished for.

My Plan is to get a AGX Xavier into the endpoint mode and get the virtual network between to Xavier.
I have done this multiple times with the old jetpack, so the steps are clear to me, but I do not get it up and running with the new jetpack. First as the original owner of this post the endpoint Xavier stuck and restarts.
And then I tried the patch you posted. This is where I am now.

The endpoint xavier is not restarting anymore, but the network is not working as well.
Not able to ping from both sides. The endpoint is just returning “Destination Host Unreachable”.
On the root Xavier the USB driver is stuck now and I cannot use the mouse or keyboard anymore… Also, the ethernet connection is dieing as well.

PS.: @WayneWWW like so? Now you can answer in two topics simultaneously…

This is not to make my work double. This is to prevent the noise from original owner.

  1. Your usb issue seems not related to the PCIe issue but seems affecting you to test pcie issue, could you fix that first? Is that hardware problem or something else?

  2. Have you validated the hardware correctness in jp4.x? If so, could you set up root port in jp4.x and endpoint in jp5.0.2 and see if they can ping each other under such situation?

Sorry to annoy you, but that’s the definition of a forum…
You look for similar things first, try to see if it is already solved, and do not start the same topic over again…
but you are the boss here.

  1. Hmm I thing it is related as it appears only when I try to get eth1 up.
    It´s been some time since I looked at the schematics, but aren´t there some tings shared between USB and pcie on the dev kit?

  2. Yes both are flashed with jp5.0.2 and on both a update/upgrade was executed.

Could you try to read the comment again…?

  1. Have you validated the hardware correctness in jp4.x? If so, could you set up root port in jp4.x and endpoint in jp5.0.2 and see if they can ping each other under such situation?

Sorry, yes I will try that.

1 Like

So, i tried all permutations of jp4.6 and jp5.0.2
The connection works if the root system is jp4.6 with both ep systems.

If the root is jp5.0.2 it doesn’t work.
If ep is jp5.0.2 no ping or anything is possible and if the ep is powered off I got a kernel panic.
If ep is jp4.6 I could not log in as the USB was not working anymore.
(I scripted the network build up routine in a service)


Sorry that I am not sure about your comment…

Did you test RP- 4.6, EP -5.0.2 case? Also, you still need to add the kernel patch I shared to 5.0.2 EP.
What is the test result of this one?

Yes, the RP- 4.6, EP -5.0.2 case works fine with your patch applied only to the ep.
I do not have the unpatched ep system anymore and would need to rebuild the kernel if that is needed as well.

Is the patch also needed for the RP?

Hi @SooMSooM

  1. That patch is only needed for EP.
  2. I also tried on my devices and here are the setup. Both jp5.0.2 devices (rp/ep) can ping each other with this setup.
  • this interface is easily to be affected by other network interface, so please try below
  1. Disable Network manager
    sudo systemctl stop NetworkManager.service
    sudo systemctl disable NetworkManager.service
  2. Set static IP
    use to set static ip address
    → sudo apt install
    → Static IP Address Assignment
    To configure your system to use static address assignment, create a netplan configuration in the file /etc/netplan/99_config.yaml. The example below assumes you are configuring your first Ethernet interface identified as eth0. Change the addresses, gateway4, and nameservers values to meet the requirements of your network.

Example for static IP setting in netplan:

  version: 2
  renderer: networkd

Please refer to Network - Configuration | Ubuntu for details

Also, remove the usb cable on the flash port to prevent the usb device mode network affecting too.

I just reflashed to rp, because this seems to be the trouble maker.
I disabled the Network-manager service and tried it again without anything else connected.
Should it work without the static IP? As I cannot use a static IP in my companies network i left it away.
Still no pinging possible :(


Why does this issue matter with your company network…? Under this setup, only two jetson connected to each other and none of them is connecting with ethernet… So company network totally not involves here…

What I am talking about is set static IP to the two PCIe eth1 interface with netplan tool.

You may use UART console to control both of them.

just to clarify, I know the company network doesn’t matter, but I thought that’s where you were going with your netplan stuff. Both systems have monitors and everything so accessing them is not a problem.

My current steps are:

  1. flash rp normally

  2. flash ep in the right mode

  3. build kernel on ep with your patch.

  4. stop and disable network-manager.service on rp.

  5. put the two together

  6. boot ep and execute:
    cd /sys/kernel/config/pci_ep/
    mkdir functions/pci_epf_tvnet/func1
    echo 16 > functions/pci_epf_tvnet/func1/msi_interrupts
    ln -s functions/pci_epf_tvnet/func1 controllers/141a0000.pcie_ep/
    echo 1 > controllers/141a0000.pcie_ep/start

  7. boot rp

  8. ep → ifconfig eth1 up

  9. rp → ifconfig eth1 up

  10. ep → ifconfig eth1

  11. rp → ifconfig eth1

And after that, I still cannot ping. Now was my question should I replace the part at 9 and 11 with your netplan stuff or should it work like this? I will now look into to set something from point 8 onwards…

Kind regards

You need to disable it on both devices…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.