Jetson AGX CUDA 10 manual installation

Hi, Is there a way to install CUDA 10 run-time libraries AND the required L4T drivers manually, without having to depend on the SDK manager?

I was able to set-up the run-time libraries manually, but I’m getting an error trying to access the file while running an executable. I guess this gets installed as part of the L4T driver installation, which I haven’t been able to install via a script. Would appreciate any feedback from anyone who has tried the manual method for CUDA 10 on Xavier.



There are some dependencies between OS, driver and CUDA toolkit.
You will need to install all of them from the same JetPack version.

If you have downloaded the package from JetPack, you can manually install the CUDA toolkit.
However, the GPU driver is integrated into the OS and cannot be installed separately.


Thanks for your answer. You are right, the driver’s integrated into the OS.

I checked on a system that already had the Linux4Tegra drivers installed, and it worked fine.