Jetson AGX does not show any signal on the screen with the LED on

I have a jetson AGX that was working fine with no problems. Once (due to some research activities), I connected the pin 4 (BUTTON_POWER_ON) of J508 to pin 1 (GND) in the carrier board.

After that, just connecting the power supply turns on the power led (no need to touch the power button) and there is no display signal on the screen. Of course, there is no jumper for an automatic boot.

I have tested the the power up sequence and the functionality of the button confirmed, but the problem still remained.

I have tried to go into recovery mode and connecting to the jetson through usb-c directly to linux, but it was not recognized, also tried to push the power on button for more than 10 seconds but it was not shutdown.

Any ideas on how to try to solve the problem?

Many thanks in advance

hello vcb1,

please setup the serial console via J501 to gather the complete bootloader logs for reference,


so i have tried to follow the steps suggested in this post Setting up a serial console for debug - #2 by mehmetdeniz

After i connect the microusb it is clear that the computer detects something. This is the result of lsusb:

and the result of detected usb after conecting in /dev/


then following the instructions of the mentioned post, i select the corresponding parameters in the gtkterm

I have tried with ttyUSB0, ttyUSB1, ttyUSB2, ttyUSB3 and nothing happens, the screen is black and there is no response.

I have also reboot many times and change the cable but the result is the same, black screen an no response.

am i doing something wrong?

Many thanks,

Hello @vcb1,

Have you connected the debug USB after the system boots up or before power up state?

Because there may nothing to print on debug connection after system boots up.
Kind Regards

Hi @mehmetdeniz thanks for the fast answer.

I have tried both (in fact i have tried all possible combinations…).

The point is that when i plug in the jetson, it starts directly (without the need of pressing the button). I am not sure if the problem comes from there and the jetson is not even starting to be able to debug.

Whatever suggestion to try is always welcome.

Does your power LED is continuously on during these tests?

@mehmetdeniz yes. As soon as i plug in the led is always on

Do you have any multimeteres to check the short circuits on your board?

You can check the pin-5 & pin-6 on J508 header connected due to somewhere on carrier board

Afterwards, you can also check the reset button on it.
Maybe the reset button stucked

I have checked with the multimeter the pins 5 - 6 and the reset button. It looks like it is ok.

I have also carefully check other pins of the board and I could not find a problem.

I am not sure if this can help, but this is the only message I get in the terminal:

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

No, i could not manage to solve the issue.

We have connected the power to the wrong ping (due to some research activities in a custom product) and i am afraid that it is an error in some of the electrical components of the board.

I have carefully checked many things together with more colleagues and we were not able to find the problem.

If you have some suggestions on how to (at least) get some log or message let me know. Up to now the only message i can get is the one of my previous answer “GtkDialog mapped …”


hello vcb1,

If you believe that your Jetson product is defective, please contact the NVIDIA Customer Care team for the RMA process.

Thanks. I have already contacted with the distributor, but the jetson is not anymore in guarantee.

Can i still contact the RMA process?

hello vcb1,

please contact with the NVIDIA Customer Care team for the further actions.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.