Jetson AGX Orin can't turn into force recovery mode


I reflashed the Jetson AGX Orin and I was trying to install SDK components but the host PC didn’t detect the jetson.
So, I tried to turn the jetson into force recovery mode.
Although I was able to do it before reflashing, now I can’t do it

How can I turn it recovery mode.

It should be the method you put the board into recovery mode is wrong…

The method to put Orin devkit to recovery mode:

Press and hold the recovery button and then

case 1. If the board is not powered on state
Press/release the power on button. And release the recovery button.

case 2. If the board is powered on state
Press/release the reset button and release the recovery button.

Also, only one type C port on the device can flash the board. Please make sure you use the right port.

I uploaded procedure video.
The host PC doesn’t detect the device and Jetson booted up after about 1 minutes.
What’s wrong with my procedure.


Please use the type-C next to 40pin header.

And please follow this order

  1. Remove your power cable so the board in power off

  2. Plug the power cable back

  3. Press and hold the recovery button.

  4. Press and release the power button (recovery button is still on-hold)

  5. Release the recovery button.

I tried it but which caused the same result

Do you have other AGX Orin or AGX Xavier that can validate your steps ?

but I uploaded the video


Is your jetson still able to boot up into desktop or able to let you operate it with console mode?

yestrerday I was able to do it

I can

please open a terminal and run “sudo reboot forced-recovery”. This is the software method to put the board into recovery mode.

I did that but after 1 munites, it booted up.

Could you dump the serial console log? and share me the log after you enter the recovery command in terminal?


I attached the log
recovery_log (90.0 KB)

Hi @taitai

Sorry for late reply. This sounds a hardware problem to me.

If you have no other module/carrier board to test, I think it might need RMA.

Thank you for your kind help.

I’m sorry to hear that but still thank you.

I’d like to RMA.
Is there any documents about that?
And can I RMA for free?

Thank you.

please follow the website here for RMA.

Thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.