Jetson AGX Orin Deepstream SDK 7.0 installation issue

I am trying to install the Deepstream SDK 7.0 on my Jetson AGX Orin board by following the official documentation. I ensured that all dependencies are installed properly and then i installed the SDK but when i am trying to verify the expected output as per given Expected Output …I am getting the following errors

(gst-plugin-scanner:306221): GStreamer-WARNING **: 19:10:42.834: Failed to load plugin ‘/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_inferserver.so’: libtritonserver.so: cannot open shared object file: No such file or directory

(gst-plugin-scanner:306221): GStreamer-WARNING **: 19:10:43.508: Failed to load plugin ‘/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_udp.so’: librivermax.so.0: cannot open shared object file: No such file or directory
** ERROR: main:706: Failed to set pipeline to PAUSED

could you share a whole log 1.log by this command-line? Thanks!

export GST_DEBUG=4   &&  deepstream-app -c "the used configuration file"  >1.log 2>1.log

i could not run the command directly so here are the steps i followed and the 1.log that i got
Step:1 → export GST_DEBUG=4
Step:2 → sudo bash -c ‘deepstream-app -c source30_1080p_dec_infer-resnet_tiled_display_int8.txt >1.log 2>&1’

1.log (2.6 KB)

here is the attached1.log file

  1. why do you need to use sudo? please execute “export GST_DEBUG=6” first, then share 2.log of “deepstream-app -c source30_1080p_dec_infer-resnet_tiled_display_int8.txt >2.log 2>&1”

  2. could you share the 3.log and 4.log after testing the following two command-lines?

gst-inspect-1.0 nvinfer >3.log
gst-launch-1.0 filesrc location=/opt/nvidia/deepstream/deepstream/samples/streams/sample_720p.mp4 ! qtdemux ! h264parse ! nvv4l2decoder ! nv3dsink sync=0 >4.log  2>&1
  1. i have to use sudo as the orin is not personally mine and is owned by some organisation so i don’t have the root access and hence it shows me permission denied if i run without the sudo and here is the 2.log file
    2.log (2.0 KB)

  2. similarly i have also used the sudo bash -c for these 3.log and 4.log to avoid permission issues
    3.log (6.8 KB)
    4.log (501 Bytes)

  1. from the log 4.log, the error is in nv3dsink display. please set DISPLAY for sudo. on my side, I did “export DISPLAY=:1 ”.
  2. you can use fakesink instead. please set type=1 in [sink0]. Using fakesink will not display video.

after setting type=1 in sink0 here’s the output that i am getting
deepstream sample run.txt (83.0 KB)
Atleast the app is running now. Thank you very much!! however i am not sure if the out was as expected as i am using the orin board remotely via terminal ssh and hence i am not able to visualize the output, so can you suggest me any other possible way to visualize this as i tried to use vnc but it is lagging tooo muchh.

from the log deepstream sample run.txt, the app did inference. you can set type=3 to record a mp4 file. please set enable=1 in [sink1].

when i am setting type=3 in sink0 and enable=1 in sink1 the app fails to run

please set type=1 in sink0 and set enable=1 in sink1 .

it is working now thank you very much for your help !!! :)

hey there, actually i am trying to run a pre-trained insightface scrfd face detection model on the deepstream but i am facing issue with parsing of bounding boxes. I have the simplified onnx format of the model which takes input in shape (1,3,640,640) and returns confidence score in following 3 bindings/tensors (12800,1)(3200,1)(800,1), bounding boxes in following 3 bindings/tensors (12800,4)(3200,4)(800,4),and 5 keypoints in following 3 bindings/tensors (12800,10)(3200,10)(800,10).

Here are the config files that i am using
dstest1_pgie_config.txt (3.0 KB)
myconfig.txt (3.8 KB)
i also tried to use python bindings by running the following file but could not do it copy_test1.txt (6.6 KB)

thanks for the update! if you encounter a new problem, please open a new topic, Thanks!