Jetson AGX Orin Dev kit analog sound not coming

Hi All,
We are trying to test Jetson AGX Orin Dev kit audio ( It has devkit BSP only , not modified) , But it is not working as expected .
2 pin - GND of headphone
5 pin - headphone out left side
9 pin - headphone out right side.
In sound setting we made sure analog audio selection
Any configuration is required ?

Any input please…

Hi vardhaman.k,

Can you confirm if your Dev Kit has onboard audio codec?
Please dump following info on target:
$ i2cdetect -y -r 31e0000.i2c

Also please share output of following:

* cat /sys/kernel/debug/asoc/components
* amixer -c APE controls

Above can help confirm if your board has onboard codec and its driver has been registered properly or not.


Audio_CMD_relatedLogs.txt (77.2 KB)
Hi Sameer PFA logs. Please check and suggest further.


Hi Sameer, Any update on this ?

Hi Vardhaman,
Thanks for your logs

Perform below steps based on your environment.

Step 1: Without building BSP

On Host :

  • Take backup of base DTB file.
  • cd Linux_for_Tegra/kernel/dtb
  • cp <file.dtb> <file.dtb>.bac
  • Apply overlay and generate modified DTB
    $ fdtoverlay -i <file.dtb> -o <file.dtb> tegra234-p3737-audio-codec-rt5640 .dtbo

For example: file.dtb => tegra234-p3701-xxxx-p3737-xxxx.dtb , use right dtb base file by referring the flash log.


Step 2: (Apply DT changes in build env.)

Please apply the attached patches to enable onboard. RT5640 codec by default, build and flash the image.
enable_onboard_codec.diff (2.0 KB)
overlay.diff (1.5 KB)

Let us know if you still face issue in playback.

Hi @mkumard ,
Step1: I am getting no such file or directory. Logs attached with ls command response. (Step1_AudioExlore1)
hmecd001409@DSC:~/BSP/Osbourne_orin/Linux_for_Tegra/kernel/dtb$ cp tegra234-p3701-0004-p3737-0000.dtb tegra234-p3701-0004-p3737-0000.dtb.bac
hmecd001409@DSC:~/BSP/Osbourne_orin/Linux_for_Tegra/kernel/dtb$ fdtoverlay -i tegra234-p3701-0004-p3737-0000.dtb -o tegra234-p3701-0004-p3737-0000.dtb tegra234-p3737-audio-codec-rt5640.dtbo
Couldn’t open blob from ‘tegra234-p3737-audio-codec-rt5640.dtbo’: No such file or directory

Failed to read ‘tegra234-p3737-audio-codec-rt5640.dtbo’

Steps2: For 2nd steps to apply patches, not able to find “tegra234-p3737-overlay.dts” files. Downloaded from “Log in | NVIDIA Developer” But it came with dtb file.
Please can you share more info or file ?

Step1_AudioExlore1.txt (5.6 KB)

Hi Vardhaman,
Are you able to apply above patch?. If so it should enable codec on your board version. Can you give a try with build and flash.

Hi Mkumard,
Overlay patch did not apply. Only With enable_onboard_codec.diff patch able to enable audio and now audio coming.
Thanks lot Mkumard. :-)

Welcome!. Also please note in the next Jetpack release the audio codec will be enabled by default.

Thanks again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.