Jetson AGX Orin Dev kit CAN Error Active

Hello there

Previously I had an issue with CAN where it would respond with ERROR-PASSIVE (1).

That problem was solved, however now I’m getting a ERROR-ACTIVE, even though I’m using the same setup. The setup is as follows:

Untitled Diagram.drawio

The commands I’m using are:

sudo busybox devmem 0x0c303018 w 0x458
sudo busybox devmem 0x0c303010 w 0x400
sudo modprobe can
sudo modprobe can_raw
sudo modprobe mttcan
sudo ip link set can0 up type can bitrate 1000000 sjw 4
restart-ms 100 berr-reporting on

Even before I even try to send a command it already gives ERROR-ACTIVE:

After trying to send a message it gives:

‘sudo dmesg | grep can’ gives:


mtt_can ctrlmode should really be 10?

Sometimes it gives:

Extra info:

Hi claudio7,

What’s your Jetpack version in use?

ERROR-ACTIVE should be the expected state.
What command did you send? Is the same command working in loopback test but failed with motor?

Please share the serial console log as file here including how you setup CAN and reproduce the issue for further check.

Jetpack version is 5.1.1

I used cansend can0 142#9200000000000000, and yes, the same command that worked in loopback test. This command is accepted by the motor protocol, as I’ve used this motor a lot of times before, with the same setup even.

sudo ip -d -s link show can0 file:
loglinkshow.txt (915 Bytes)
dmesg file:
logdmesg.txt (75.2 KB)

to set up CAN I use:

And I’ve just reproduced the error, and the same thing happened. I’m using this CAN transceiver btw:

Could you verify with the latest JP5.1.2?

[  251.936887] net can1: mttcan device registered (regs=0000000036db5e9d, irq=116)

And also tried if can1 would hit the same issue?

I would also like to know the result if you don’t use sjw 4 in this case.

Do you have other CAN transceiver like SN65HVD230?

I was testing the can1 like you suggested and it worked. Shoked without knowing the reason why, I changed back to can0, and I was even more shoking when I realised it suddenly worked. I don’t know why, didn’t change anything.
Anyway, thank you for the support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.