Jetson AGX Orin dev kit static IP setup problems

The orin dev kit needs to be setup a static IP of for it to talk to other devices in the application over which I dont have control.
I tried setting up the static IP by adding the following to the “/etc/network/interfaces” file.

auto eth0 
iface eth0 inet static

After a reboot, the eth0 interface does show a valid IP of “” but does not communicate to any other device connected to it. I have also tried using a crossover adapter like this

The weird thing is that if I use a switch between the other devices and the Orin dev kit with this same static IP setup, everything just works. I cannot really use a switch in my application.

Can anyone help me with what is going on and how can this be fixed?

I’m closing this topic due to there is no update from you for a period, assuming this issue was resolved.
If still need the support, please open a new topic. Thanks

Hi krunaljc1,

Could you help to run dhclient -r as root to kill dhclient?
and also provide the result of ifconfig eth0 after reboot.

So, with or w/o this crossover adapter, you can not ping to other device?
Do you try other ethernet cable?