Jetson AGX Xavier Industrial Boot Up Issue


We are using Jetson AGX Xavier modules on our custom carrier board. The AGX Xavier 32gb and 16GB are working good but AGX Xavier Industrial module is not booting up. We are using SRC0GS22D IC in our carrier board. How we can solve this issue?

Additionally, the Industrial module boots up on AGX Xavier Dev. Kit’s carrier board.


1 Like

Did you read the interface comparison doc in DLC? Is there any difference on the interface design, like pin E10 is unconnected or not? You need to check and compare your design to that of P2822 to find out risks. Generally, JAXi should be able to work on the carrier board that JAX can work on.

Hello @Trumany

Yes, we checked it. The H60, E10, E61, D60, D62 and F60 are not connected. Also L44, L45, L47 and G59 too


Please compare that carefully, it should work if it is totally same to devkit.

Hello Trumany,

We are using the “Power-On No MCU” approach together with “Auto Power-On Option No MCU” as mentioned in Product Design Guide, which works flawlessly for AGX Xavier regular modules. We also checked the devkit schematics, where the No-MCU option is left as nonstuffed. We confirmed that our design is same as this nonstuffed circuit as well.

If you can suggest a solution for us, I would be pleased.

Hi, I would suggest to capture the power on sequence waveform of your board and compare to that of devkit. As you can see in product design guide, there is power sequence diagram for your reference, even you think your schematic is correct, it needs the sequence to verify still.

Thanks for the answer. We will try to capture the sequence. I just want to know if as NVIDIA did you try the alternate non-assembled circuitry without a sequencing MCU for powering up AGX Xavier Industrial Module? Because we have exactly same circuitry on our design and it is working flawlessly with AGX Xavier standard modules. We will try to look waveforms using oscilloscope, but in the meanwhile if you have some suggestions to check on circuitry we would be very pleased.

The circuit design in design guide has bee validated. Please check the power on sequence first.

Hi @emrerrdhx
Did you found out what was the problem? We have a similar issue, but only at low temperatures. Any help is really appreciated.
Thank you.

Hi @sevm89
We are still working on the issue and did not come up with a solution yet. We were not aware that this issue happens at low temps but after your comment, we warmed up the module in devkit and then tried again in our custom carrier board and it booted successfully.

Also, we used an oscilloscope to observe the power-up sequence for both low temps and high temps. I’m sharing it here in case it helps.

High temps:

Low temps:

Thank you for your answer and the power-up sequence.
Does your carrier board in the cooled case never turn on? Because in our case, the CARRIER_PWR_ON is high (Carrier Board on) and also the SYS_RESET_N is released by the Module, but the System just stays in that state.

Facing the same issue.
Did you guys get any solution for this?

Ashik P.

Hi Ashik.p

Until now we do not have a solution.

Best regards

Hi @ashik.p @emrerrdhx

Did you solve the problem?
Do you have a backup battery or capacitor connected to the Pin VCC_RTC?
We have found out that the system always boots when we disconnect our battery or capacitor from the VCC_RTC Pin of the Xavier industrial. Is it the same for your carrier boards?
Thank you.

1 Like

Hi @ashik.p @emrerrdhx

Were you able to solve this? Was it also the VCC_RTC?
Thank you.

Best regards

Hi @sevm89

Yes, we just solved the issue with help from NVIDIA team. In our design, values of marked components were different from design guide in Figure 5-5. Capacitor was 0.47uF and resistor was 47k ohms, taken from devkit schematics. Restoring them to their original values, 0.1uF and 10.5k ohms, solved the issue for us. Now it’s working with both regular and industrial AGX Xavier.

We are using a supercapacitor on VCC_RTC, but we never tried removing it so I have no comment on that one.

Best Regards

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.