Jetson AGX Xavier Industrial SOM extend rootfs size failed


We used the JAXI SOM with JetPack 5.1 on our project. But the default ROOTFS SIZE is 28GiB, and I tried to extend the ROOTFS SIZE to 58GiB with option -S, which caused fail to reflash EMMC.

I have referred to the discussion below, but the result is different:

Error Snapshot:

Full Log:

command: sudo bash -x -S 62277025792 jetson-agx-xavier-industrial mmcblk0p1

board_flash_20230715-094316.txt (721.1 KB)

Hermes Wu


can you try directly running again with sudo ./ ..., and without bash -x?
These control characters make the log very hard to read.

Also, are you able to flash it without the -S option?
It did not even enter the process where partitions were actually written into the storage device, so maybe the issue is not about the APP partition size.

Hi @DaveYYY

I have tried what you mentioned before, the results are as below:

  1. sudo ./flash ... without bash -x: Failed, the same error with I posted.
  2. sudo ./flash ... without -S: OK, but only uses 32G(Rootfs Size = 28GiB)

Hi @DaveYYY

I tried JetPack 5.0.2 with the same command this morning, and it works fine.
Is there any difference in between JP 5.0.2 and JP 5.1?


it may be a bug in the partition layout file, and we can re-produce this issue on our side.
We’ll see if we can get it fixed, and report here given any update.

Hi @DaveYYY

I modified the EMMC config file bootloader/t186ref/cfg/flash_l4t_t194_spi_emmc_jaxi.xml, and then it works.
the patch is as below:

--- flash_l4t_t194_spi_emmc_jaxi.xml	2023-07-17 15:33:15.851251745 +0800
+++ flash_l4t_t194_spi_emmc_jaxi.xml	2023-07-17 15:31:30.415759099 +0800
@@ -690,7 +690,6 @@
         <partition name="RECNAME" type="kernel">
             <allocation_policy> sequential </allocation_policy>
             <filesystem_type> basic </filesystem_type>
-            <start_location> 0x70C100000 </start_location> <!-- aligned to 0x100000 -->
             <size> RECSIZE </size>
             <file_system_attribute> 0 </file_system_attribute>
             <allocation_attribute> 8 </allocation_attribute>


Yes, this is what I’m just going to post, but I’m checking with our developers about why they have such limitation.

Hi @DaveYYY

OK, If this change will be caused any issues, please help to inform that.


the limitation is about working with OTA, so I think if you don’t use them, then it’s safe to remove it.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.