Jetson AGX Xavier on Ubuntu 20.04 with Jetpack 5.0.2 Flash issue


With the new Jetpack 5.0.2, I tried to flash the Jetson Xavier with the sdk manager. The packages on the host 20.04 ubuntu system gets installed but when I try to flash the Xavier, I get the following error, " Jetson Xavier is in a bad state "


To get around this, I manually flash the device by getting inside “Tegra_for_Linux” and using the command
$ sudo ./ jetson-agx-xavier-devkit mmcblk0p1. But, I get the “yaml module not found error”

Can anyone please help regarding the issue?

Hi anshulnayak,

Please run below command on your host machine:

sudo apt update
sudo apt install python3-yaml

And flash image by manual again. Thanks!

Hi carolyuu,

I followed the instructions as mentioned by you. Even after sudo apt install python3-yaml, I get the following error. in fact, yaml was already installed. Do I need to provide some instructions to script so that it knows it runs on python3?

Hi anshulnayak,

Can you also try below command?

$ sudo pip3 install yaml
$ sudo pip install yaml

HI Carolyuu

I have tried both the above pip commands. It does not work.

Further, I had multiple python3 --versions and fearing that one of the python3 might not work, I ran each pthon3 version in a virtual environment load the packages using pip command but still the error persist.


ls -l $(sudo which python3)

That is the python being used.


I figured out few points regarding the python issue:

a) Installation of anaconda interfered as my anaconda had python 3.7 which was a different version from python 3.8 where I was trying to perform pip install.

b) Further, the second issue I had was my default python was in /usr/bin/python3 (which python) and I had other distributions in /usr/local/bin/python3 . So I created a symlink between the two using :

sudo ln -sf /usr/bin/python3 /usr/local/bin/python3

Thank God, atleast the flashing started. But, midway, the flashing stops with the error as below. I faced the same issue when installing with ubuntu 18.04 host.

FYI: This is not the first time the board is getting flashed. It has been flashed multiple times. However, on connecting the screen with HDMI, there is no output. So, I am refreshing this and got the error.

Sounds to me you don’t have a clean Ubuntu installation. Those other stuff you’ve installed may have conflicted with Jetpack utilities. Can you try a fresh Ubuntu 20.04 to try flashing JP 5.0.2, or fresh Ubuntu 18.04 to try flashing JP 4.6.x?

Hi anshulnayak,

Are you using default BSP package to flash image? or change any files?
Can you download BSP package again for clean and try again?

Hi Carolyuu,

I downloaded the default L4T driver package (BSP) and sample root file system for the AGX-Xavier devkit and followed the instructions as below.

But, still the same error persists as before with “br_bct_mb1” . Flashing T186 failed. It is further interesting that the xavier should be T194, why it says "T186 failed " at the end which seems bit counterintuitive.

Can you explain what is this br_bct_mb1 that it tries to download and fails after that?

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.


Please set up the uart console first.

Make sure you are in a status that you are sure you can dump uart log.

Open the uart console, and start to flash your board in another terminal. Check the log is coming out from both host side and device side, then attach both logs here.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.