Jetson AGX XAVIER SDK MANAGER ERROR

Hello all,

I am very confused due to below issue. I flaseh AGX properly and login with user name and password but when the installation bar fills up to 41.6% the errors occurs. But I cannot figure it out properly even i read L4T document.

Could not connect to the target device. Verify that:

  1. The device is connected to this host machine with a USB cable.
  2. Ubuntu ‘System configuration wizard’ is completed on the device.
  3. Jetson’s Ubuntu OS is up and running.
  4. Jetson USB device mode service is started successfully.
  • See readme file in the auto-mounted “L4T-README” folder for more details.

Could you help me?

Also terminal gives this information:

dserbes1@duygu:~ ip addr 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000 link/ether 98:e7:43:80:27:db brd ff:ff:ff:ff:ff:ff 4: wlp110s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000 link/ether 4c:1d:96:3f:07:4b brd ff:ff:ff:ff:ff:ff inet 192.168.1.251/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp110s0 valid_lft 72423sec preferred_lft 72423sec inet6 fe80::1c6f:11ec:80f7:3d0e/64 scope link noprefixroute valid_lft forever preferred_lft forever 11: enp0s20f0u1c4i2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000 link/ether 82:b0:3d:53:8c:0d brd ff:ff:ff:ff:ff:ff 14: enp0s20f0u3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000 link/ether 82:34:34:9c:c0:42 brd ff:ff:ff:ff:ff:ff inet 10.42.0.1/24 brd 10.42.0.255 scope global noprefixroute enp0s20f0u3 valid_lft forever preferred_lft forever inet6 fe80::3a67:474c:60e0:4834/64 scope link noprefixroute valid_lft forever preferred_lft forever 15: enp0s20f0u3i5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000 link/ether 32:9d:e8:f0:80:f6 brd ff:ff:ff:ff:ff:ff dserbes1@duygu:~ lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 006: ID 0955:7020 NVidia Corp.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 8087:0029 Intel Corp.
Bus 001 Device 005: ID 0bda:565c Realtek Semiconductor Corp.
Bus 001 Device 004: ID 0a5c:5841 Broadcom Corp.
Bus 001 Device 012: ID 05ac:12a8 Apple, Inc. iPhone5/5C/5S/6
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I don’t know if this will help or not, but the following is probably of interest…

You were at a stage where flash had completed, and the Jetson would have rebooted. This is no longer in recovery mode.

This first boot requires adding an account name/password. If this is not complete, then it is not possible to continue with the step of adding optional packages. You would probably want a monitor/keyboard attached during the flash, or at least a serial console from which to complete the first boot setup.

Once this is done the SDKM can look for the Jetson at the specified IP address (in this case “192.168.55.1”). If the Jetson is not fully booted, then this address will not be found. In this case the address is via a virtual wired ethernet over the USB-C cable. Sometimes the host PC will not just trust a USB virtual ethernet without the end user’s ok. If you monitor (from the host PC) “dmesg --follow”, and then disconnect and reconnect the USB-C, you should see a MAC address for the virtual ethernet if the Jetson is running at this stage. “ifconfig” should list an interface with that MAC. If not, then you can use something like “nm-connection-editor” ("sudo apt-get install network-manager-gnome") or the local GUI tool and enable the interface associated with that MAC address.

Once that network is reachable you should be able to use ssh with that address (but if you have not created an account yet on the Jetson, then it won’t matter that ssh works).

You can also try to change default IP from 192.168.55.1 to DHCP assigned IP of jetson AGX (run ‘ip addr’ on AGX) and retry