Jetson Devkit B00: Stuck in uboot env

Hi,

my mistake i changes the dts file to incorrect one throw extlinux file. (my devkit dont have SD card slot).
now when the system boot into kernel it collapse and i only have accsess to uboot.

how can i change the extlinux, or fix this state.

Thanks in advance,
Roee.

Could you provide a boot log so that we can know what is your current situation?

I’ll also suggest that if you have access to the extlinux.conf (e.g., maybe you had it on the host PC and copied it over), then you might post that as well. Along with stating if this is a dev kit or a third party carrier board.

Tip: Also, from the boot console, you might check out the result of the command “printenv” (I think that is what it is, but it might just be “env”…haven’t looked in awhile).

Hi Linuxdev,

Thank you for your fast response,
i flash the EMMC and now the Linux back online again.
but for some wierd reason the remote ssh don`t work,
i got message: “Connection reset by 192.168.0.9 port 22” (i think the Jetson block my connection on this port).
ping from host to unit, work.

i tried this steps:
sudo apt install ufw
sudo ufw allow ssh
sudo ufw allow 22
sudo ufw enable
sudo ufw status

but without any seccsess,
please advice on how to fix that.

Many thanks,

As a test, first ssh from your account on the Jetson to itself. If your user name is “ubuntu”, then for example, while logged in to the Jetson, does this work?
ssh ubuntu@127.0.0.1

If it does, then from the Jetson, what do you see for the output of the commands “ifconfig” and “route”? Then, from the host PC, what do you see from those same commands (ifconfig and route)? Ping works, so those are probably compatible networks, but it is worth looking at those in case there is something unexpected.

Hi,

When trying to send ssh from Jetson terminal againts localhost (127.0.0.1) it said,
“connection reset by 127.0.0.1 port 22”

i think this port is not enable on the Jetson or blocked.

Basically, it is not the network outside rejecting ssh. What do you see from:
systemctl status ssh.service

Reflash the board again with Nvidia flash utility solved my issue.

Thanks a lot.