Jetson DOA out of box. help me mr. wizard!

Hi All,
After plugging in my Jetson board for the first time, fresh out of the box, and all I get is a blank screen. The green LED is on, and the fan is running. I tried the reset button and the other two buttons for good luck, but alas did not receive good luck. Does anyone have any suggestions?


Check the serial console/DB-9. 115200 8N1. Lots can go wrong with video while the board is ok.

Thanks! At the risk of showing my ignorance, how do I do that? I gather I’d connect to host with the serial port. And then do what?

I hope I haven’t gotten in over my head. I don’t have much knowledge of operating systems beyond being a user. The instructions and unboxing video made it seem like I should expect to be able to plug the thing in, and it would come to life. I guess there’s more to it than that.


How do you have it hooked up to your monitor?

hdmi cable from the board’s hdma socket to the monitor. The monitor reports “no signal” when I power cycle the board, or unplug the cable. So I assume that when the board is powered, it is producing some kind of video signal.

I’ve tried this with nothing else attached to the board, and with a keyboard in the USB3 plug. Is there some other cable or peripheral I need to attach before the board can wake up?

The board should work “as is”, but video does have requirements for graphics mode to work (e.g., old style 15-pin VGA adapters cause failure because they lack the DDC channel).

The DB-9 serial port can be connected with a NULL modem cable and a console is always available there, even before boot loader finishes. This serial port does not require graphics, so it is extremely reliable at providing root access even when video and networking are completely gone. This would include log access and error message access. If you lack a DB-9 port on your host you can get a USB “serial UART” which the USB part goes to host and has a DB-9 at the other end for connecting to the Jetson serial port.

It’s Alive!!! I didn’t have a serial/usb cable, so I tried an Ethernet cable. Then I could putty in. Thanks for the help, everyone! I’ll start a new thread when whatever I try to do next fails. Cheers,