Jetson doesnot power up and I can't put it in recovery mode for flashing through host computer

I have been developing my Final Year Project on Jetson for 6 months now. It worked fine for all that time but last week, the OS on Jetson did not allow us to log in. I flashed it again and tried installing OpenCV with Python. In the middle of the installation process, it got stuck and didn’t respond so I restarted Jetson using the Restart Button. It didn’t start again. The green light power and the fan spin that occurs on startup don’t occur anymore. It looks like the jetson is dead as there is no light on jetson right now. I have tried putting it in recovery mode to flash it again but that doesn’t work either.

Can you measure the power supply voltage? It sounds like the board has died (the power LED should work even if flash failed), but power supply is also a possible problem. Do beware that even a Jetson should have the power supply on a surge protector, it’s like any other computer in that regard. If you find the power supply is good, you can find RMA instructions at the top of this URL:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

First you can take this topic as reference to check the power rails and power on sequence : https://devtalk.nvidia.com/default/topic/1000444/tx1-does-not-power-up/