Jetson Expansion Header Tool Configuration Cannot Be Saved

Hi there,

I tried to set up spi interface on the Jetson AGX Xavier through the 40 pin connector. Below is what I did.
Step #1: I go in (sudo /opt/nvidia/jetson-io/
Step #2: select “spi1”, then pin 19/21/23/24/26 shows “spi1”
Step #3. Save and reboot;
However, after reboot, I go in this tool again (sudo /opt/nvidia/jetson-io/, pin 19/21/23/24/26 are back to “unused”.
I tried to send commands out from those pins. Not working either.

Could you let me know what can be wrong? My jetpack version is 4.4 DP with system booting from SSD.
And please note SPI configuration worked before when my Jetpack version was 4.4 production release with system boot from SD card. Does it have anything to do with these two differences or just a coincidence?

This tools only to Nano/NX not support AGX Xavier.

Interesting. It worked before on my Jetson AGX Xavier. Has anything changed?

If not this tool, could you please let me know how to enable the SPI interface on Jetson AGX Xavier?

Please refer to below topics: