Jetson inference "collecting your own detection datasets"

I’m working with jetson inference and am trying to collect my own dataset and training the model. I created a folder called “example” in jetson-inference/python/training/classification/data and made the txt file. Then, I ran the camera-capture dev/video0 command on terminal. When I put the paths to the folder and the txt file, I get an error saying “failed to create data set subdirectory //train” “failed to create data set subdirectory //val” “failed to create data set subdirectory //test”. I think this might be the issue? Am I inserting the wrong path?

Anyways, after I collect the images, I run the command “python3 --model-dir=models/example data/example”. But then I get this:

Use GPU: 0 for training
=> dataset classes:  2 ['airpods', 'lysol']
Traceback (most recent call last):
  File "", line 506, in <module>
  File "", line 135, in main
    main_worker(args.gpu, ngpus_per_node, args)
  File "", line 191, in main_worker
  File "/usr/local/lib/python3.6/dist-packages/torchvision-0.7.0a0+78ed10c-py3.6-linux-aarch64.egg/torchvision/datasets/", line 208, in __init__
  File "/usr/local/lib/python3.6/dist-packages/torchvision-0.7.0a0+78ed10c-py3.6-linux-aarch64.egg/torchvision/datasets/", line 100, in __init__
    raise RuntimeError(msg)
RuntimeError: Found 0 files in subfolders of: data/example/val
Supported extensions are: .jpg,.jpeg,.png,.ppm,.bmp,.pgm,.tif,.tiff,.webp

I think the issue might be that there isnt anything in my val folder?? But I’m not sure what’s supposed to be in my val folder? The captured images are all in the train folder

i fixed this just by copying the images from train to val

1 Like