Jetson-inference failed to load network

I have a question about jetson-inference.
I use jetson Xavier NX developer kit and jetpack4.4.
I tried to move the sample code with reference to dusty’s video.
However, I couldn’t run sample code.

Exception: jetson-inference – detectNet failed to load network

By the way, I tried other detectNet code but it doesn’t work as well

I’m a beginner, so I can’t figure out the cause.
help me!!

Thank you

Hi @kazuki.yumiba, can you post the full console log of when you try to run the program?

Can you also check that the models were downloaded to your jetson-inference/data/networks/ directory? For example, you should have the file jetson-inference/data/networks/SSD-Mobilenet-v2/ssd_mobilenet_v2_coco.uff

If you are missing the models, you can try downloading them again like this:

$ cd jetson-inference/build
$ ./
1 Like

Hi dusty_nv.
Thank you for reply!

I tried your suggestions.
I was able to run the code thanks to your suggestions.

However, There is one concern.
When I ran my code, Red letters appear
could not register plugin creater - ::FlattenConect_TRT version 1

Is it OK?
If you know anything please tell me?
Thank you.

You can safely ignore the error, so not to worry.

Hi ! dusty_nv.
I deeply thank you for always providing the best suggestion and the best code.

If you are in trouble again, please help.

Thank you.