jetson inference segment net


I am using jetson inference with gst-Pipile Class ( to use my Rtsp streams.
The segment’s app crash, but i found that if I comment out this piece of code, see below, in the overlay function inside segNet.cpp, the app does not crash, but the image is

px_out[0] = alph * c_color[0] + inva; // * px_in[0];
px_out[1] = alph * c_color[1] + inva; // * px_in[1];
px_out[2] = alph * c_color[2] + inva; // * px_in[2];
px_out[3] = 255.0f;

I would like to know why if a comment out the app dont crash.


Hi francesco1990, can you please provide the command you are using to launch SegNet?

Are you running a custom-trained model? If so, have you provided a file containing the overlay colors for each class?


I dont use a custom model. I have try to all model download from, and the models have the same result.

The command that i use is:
./segnet-camera fcn-alexnet-pascal-voc root:root@ 1280 960

I update the dimension in all part of the segment.cpp

If can be helpful i link my fork :

What happens if you try a different model, like cityscapes or the aerial model instead - does it still crash?

Also what occurs if you run segnet-console on a test image instead of segnet-camera.

I tried this model and it crash.

When I use the gstCamera class insted of gstPipeline class it goes with out problem.

It can be a problem in the way I manage the decode/encode in the pipeline?

It may be related to the resolution or number of channels in the output image buffer that you are feeding segNet. It expects 4-channel float32 RGBA images. Does the output buffer you are passing segNet::Overlay() have 4 channels?