Jetson Inference takes too long to start the program

I run Jetson Inference from Docker, using Python and with my camera USB /dev/video0/

But, it took more than 10 minutes to start. I use a Jetson Nano 2GB. I don’t know if it’s normal or not, but it takes that long every time I run it, not just the first time.

Note: CPU usage is always full, to the point that it slows down for a few seconds … and almost at the end an alert/warning appears that I have low memory (I don’t know if RAM or SWAP), but, I have little space in microsd… I don’t know if that could be a possible cause.


Please note that the app will convert the model into TensorRT engine when the first time launch.
It takes some time to finish since TensorRT try to find an optimal algorithm based on the hardware.
This is an one-time job and you should be able to find a serialized file on the model folder.

Could you check the output log to see if the app converts the model every time.
If yes, it may meet some issue when serializing the engine file (ex. no writing permission).


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.