Jetson-io does not work on L4T 32.5.1

Hi! I have troubles starting jetson-io to configure the 40-pin header. It was working before I upgraded to L4T 32.5.1. When i start jetson-io, the screen flashes for a bout 1 sec (where I can sort off see the app building up) and then exits. I started jetson-io with the command to get the error message, which returned the following:

findfs: unable to resolve ‘PARTLABEL=APP’
[?1049h[22;0;0t[1;55r(B[m[4l[?7h[?1h=[39;49m[39;49m[37m[40m[H[2J =================== Jetson Expansion Header Tool =================== |[3;71H| |[4;71H| |[5;71H| |[6;71H| |[7;71H| |[8;71H| |[9;71H| |[10;71H| |[11;71H| |[12;71H| |[13;71H| |[14;71H| |[15;71H| |[16;71H| |[17;71H| |[18;71H| |[19;71H| |[20;71H| |[21;71H| |[22;71H| |[23;71H| |[24;71H| |[25;71H| |[26;71H| |[27;71H| |[28;71H| |[29;71H| |[30;71H| |[31;71H| |[32;71H| |[33;71H| |[34;71H| |[35;71H| |[36;71H| |[37;71H| |[38;71H| ====================================================================[2;52H[9;31HFATAL ERROR! | Command ‘findfs PARTLABEL=“APP”’ returned non-zero exit status 1.[15;24HPress any key to terminate[?1l>[39;49m[40d[K[40;1H[?1049l[23;0;0t[?1l>jetson@jetson:/boot/dtb$

Not quite sure what to make from this. Does this mean that I cannot run jetson-io because I am booting from SSD and findfs gets confused by this?

Any help welcome…

Cheers
Florian

Use parted or gparted to set the name of the partition that contains your /boot directory to APP.
Not the filesystem label, but the partition name.

For parted, assuming the device that contains the /boot partition is /dev/sda1…

$ sudo parted /dev/sda name 1 APP
## Verify
$ blkid /dev/sda1

You don’t even have to reboot.
Don’t forget, substitute sda1 with your correct device.

1 Like

Hi gtj

Thanks for the that! findfs is now resolving properly. But, well, what can I say:

jetson@jetson:~ sudo /opt/nvidia/jetson-io/jetson-io.py | tr -d '[:cntrl:]' [?1049h[22;0;0t[1;55r(B[m[4l[?7h[?1h=[39;49m[39;49m[37m[40m[H[2J =================== Jetson Expansion Header Tool =================== |[3;71H| |[4;71H| |[5;71H| |[6;71H| |[7;71H| |[8;71H| |[9;71H| |[10;71H| |[11;71H| |[12;71H| |[13;71H| |[14;71H| |[15;71H| |[16;71H| |[17;71H| |[18;71H| |[19;71H| |[20;71H| |[21;71H| |[22;71H| |[23;71H| |[24;71H| |[25;71H| |[26;71H| |[27;71H| |[28;71H| |[29;71H| |[30;71H| |[31;71H| |[32;71H| |[33;71H| |[34;71H| |[35;71H| |[36;71H| |[37;71H| |[38;71H| ====================================================================[2;52H[9;31HFATAL ERROR![12;8HMultiple DTBs found for NVIDIA Jetson Nano Developer Kit![15;24HPress any key to terminate[?1l>[39;49m[40d[K[40;1H[?1049l[23;0;0t[?1l>jetson@jetson:~

I’ll play around a bit to figure out the next issue. If you have any advice, very welcome!

Cheers
Florian

That’s the file system label, not the partition label.

You should see something like this…

/dev/sda1:  UUID="bfe66c8e-fc51-4c17-b851-29cc014c057a" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="APP" PARTUUID="6700fba9-aefd-4d2d-aeb7-bea5c2f14a9a"

Did you run the parted command?

Yes, I ran the command. Second time around, it worked (guess I made some mistake)…Now I am stuck on multiple DTBs…Geez… =)

Yep, been there. :)
If you move all of the dtbs out of the /boot directory except the base one (either tegra210-p3448-0000-p3449-0000-b00.dtb or tegra210-p3448-0000-p3449-0000-a02.dtb) it should work. Leave all the dtbo files of course.

1 Like

Hi gtj

I removed all dtb files except: kernel_tegra210-p3448-0000-p3449-0000-b00.dtb
Had 3 more in there for a fix for L4T 32.3, which I ran before…Anyways, jetson-io works now! awesome!
Thanks a ton for the help!!!

Cheers
Florian