Jetson isn't booting

I have been trying to set up the AGX Orin 64GB and went through the Getting Started guide to set it up. After doing that, I tried to set up Isaac ROS via the Getting Started guide, but this ultimately did not work. I kept seeing errors with a “Broken Pipe” among other things such as “nvidia-smi” not being a valid command. After searching through the forum and trying out their solutions, I finally did “sudo reboot” per their instructions, and now when i try to turn the Jetson back on, it shows the bootup screen (none of the keys do anything), and then quickly shows a bunch of text (I added some images of what I saw above), then turns off and won’t turn back on. Any advice here? I’d like to get the Jetson back to its out-of-box configuration so I can start this whole process again, and I am not sure where it went wrong in the first place given that I have been following the provided guides. Thanks for the help.

Which JetPAck SW you’re using?
Are you following the instruction from Isaac ROS 2.0.0 released - Jetson & Embedded Systems / Announcements - NVIDIA Developer Forums?

I used this guide for Isaac ROS

And for Jetpack version, I followed this guide:

But I believe I had an earlier version of L4T because when i ran cat /etc/nv_tegra_release I never saw R34 Rev 1.

Then could you try with JetPack 5.1.2 with the provide link again?

You can try to learn how to dump text log instead of taking picture on the screen…

I’m not sure what you mean by that. I do not have access to an Ubuntu machine, so I used minicom on Mac to get the serial output from the Jetson, attached below:
console.txt (172.1 KB)

  1. The board is still able to boot up as your serial console has this

buntu 20.04.6 LTS vivodisk-desktop ttyTCU0
vivodisk-desktop login:

If you want us to do further check, please use this console to login your board and share /var/log/Xorg.0.log. Your system is not “isn’t booting”. It is just somehow the desktop GUI is not able to launch.

  1. BTW, your log file got truncated in each line if you don’t know that.

  2. What kayccc is trying to say is actually Jetson development always require another x86 ubuntu host there. The role of that host is to flash the board when the board cannot work normally.

Ah I see what your are saying. How can I flash the board to get it back to factory so I can use the Jetpack 5.1.2 and the new set up guide? Here’s the log too
Xorg.0.log (13.2 KB)

The xorg log gives the hint.

[ 19.897] (II) Loading /usr/lib/xorg/modules/drivers/
[ 19.913] (EE) Failed to load /usr/lib/xorg/modules/drivers/ cannot open shared object file: No such file or directory
[ 19.913] (EE) Failed to load module “nvidia” (loader failed, 0)
[ 19.914] (==) Matched modesetting as autoconfigured driver 0

Does this get accidentally deleted on your jetson?

It might have, I’m not really sure. Is there any way to get it back?

Also, when i run nvidia-smi it returns Failed to initialize NVML: Driver/library version mismatch

You won’t get nvidia-smi on Jetson platforms; it’s for dedicated GPU with PCIe interfaces, while GPU for Jetson is directly integrated into the SoC.

How could I get this back?

If you don’t know how you got it deleted, then don’t need to think about getting it back.

You could probably remove more than just this one file based on my past experience. Please just reflash the board.

Is there a comprehensive guide I can follow to reflash my Orin? I’m fairly new to all this and do not want to mess anything up

Did you ever use sdkmanager before?

I mean, didn’t you flash the board before?

No I’ve never used it. I immediately started using the Orin out of the box according to its Getting Started guide

Please prepare another ubuntu 20.04 x86 host pc to install sdkmanager.

Put the jetson board into recovery mode and let sdkmanager reflash it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.