Jetson Jetbot Robot Class Timeout Error


After my first boot of my Jetson nano I attempted to follow along the tutorial to get the nano to use it’s attached wheels unfortunately I discovered 2 problems, the LED for the supplied waveshare jetbot does not light up as it should and this message gets displayed everytime I run the command, I’ve looked for anything that could be blocking the connection but have so far failed to find anything.

Anything suggestion would be appreciated!

Hi Staffsbane,

Thanks for reaching out!

The error printed above indicates that the Jetson Nano is having difficulty communicating with the Motor driver over I2C. The OLED display also communicates over I2C. Perhaps it is an i2c permissions issue.

Are you using the JetBot SD card image?

Best,
John

Yes I am using an SD card image, I followed along using the Waveshare Tutorial provided here: https://www.waveshare.com/wiki/JetBot_AI_Kit

Using jetbot_image_v0p4p0.zip here: https://drive.google.com/file/d/1G5nw0o3Q6E08xZM99ZfzQAe7-qAXxzHN/view

Unfortunately now the robot has stopped powering on, I’ve been suggested by waveshare to use this command to find out if there’s something wrong with the i2c address:

i2cdetect -y -r 1

Unfortunately, I don’t know why robot suddenly stopped displaying anything on screen:

117609133_217428736361001_6518502572841521758_n

117772733_348677729489187_367291946970571371_n

Do you have an idea why I’m having problems getting things to display via hdmi? It was working just a few days ago only to stop working after charging up my batteries

Hi Staffsbane,

Apologies for the delayed response. I’m sorry to hear that the JetBot is behaving differently after charging the batteries.

I would first try to address if this is a hardware issue, and if so where the issue lies. Have you tried booting the Jetson Nano without the JetBot attached?

I would try this with power directly connected to the Nano, and all wires the the robot removed. Please use caution, I believe the power adapter that Waveshare ships for the Robot base is 12V, while the Jetson Nano power barrel is 5V.

Please let me know if you run into any questions testing this. I look forward to hearing back with your results.

Best,
John