Jetson Nano 2gb Headless Mode Not Working

Hello there!
I have a Jetson Nano 2gb that is not booting without a HDMI cable and monitor attached.
I gave up on it being a linux problem as I have two sdcards; one with the base image of 4.4 and the other customized.
I tried the rootOnUSB process jetsonhacks perscribes to get root to use a usb connected ssd via a SATAIII to USB cable. Then the problems started. The machine stopped booting without a HDMI cable and monitor attached. Thinking it was something in the process i messed up i switched back to the base image sdcard but am still having the same issue. Any assistance would be greatly helpful!

Hmm. I am not sure what is done by jestonhacks tutorial.

Please share me the serial log from uart console so that I can debug your problem.

Or if you just want to restore it to base, maybe you can try sdkmanager to reflash both your device and sdcard too.

1 Like

so i did some further digging and it was the usbtoroot jetsonhacks that broke just that SD card image, i disconnected and reconnected everything with the base image sd card and it worked correctly again.
Not sure why this is occurring but found that using the suggestion to black list some tegra inits in the boot args worked: