Jetson Nano 2GB SD image keeps fragmenting my microSD card

I’m having a really bizarre issue when I try to flash the microSD card with the “Nano 2GB” image. I follow the instructions perfectly - promise. This isn’t my first rodeo with using dd; in fact I use it all the time.

I have a 64GB microSD card. When I start copying the image over, the partition manager shows quite a few partitions being created, something like 14 or 15, with the last one being a bit larger in size. Then suddenly it stops with an error saying it ran out of writable disk space … even though it’s a 64GB SD card.

Funny thing now is that after I reformatted it, it’s now reporting as only having 58GB … so shrugs something got donked up.

At any rate - I’ve tried running the command just like the instructions say, where the unzip is piped directly to dd. Same thing. I’ve tried unzipping the card image separately, then dd-ing the sd-blob.img to the card … same anomaly.

I’ve never seen this sort of problem before.

But - before I go ruining another 64GB card; I wanted to see if anybody knew what was going on with this.

Anything, at this point, would be helpful :)


Hi PhobosTech,

We tried command to write the zipped SD card image to the microSD card, no issue.

$ /usr/bin/unzip -p ./ | sudo /bin/dd of=/dev/sdc bs=1M status=progress
14386200576 bytes (14 GB, 13 GiB) copied, 791.006 s, 18.2 MB/s
0+171834 records in
0+171834 records out
14400094208 bytes (14 GB, 13 GiB) copied, 907.652 s, 15.9 MB/s

I used 32GB sdcard and run on Ubuntu 16.04 host machine.
Please format your sdcard and try again.

Ya, unfortunately that’s exactly what I attempted to use as well. I tried it multiple times. I finally had to yield and use the recommended flashing software … Balena Etcher.

Oh well - at least it’s loaded properly.

Whether or not it works, is another matter entirely :P