Jetson Nano 2Gb WiFi setup error

Hi;

I’m trying to setup my Jetson nano headless mode. During configuration I provide to WiFi’s WPA/PSK key but WiFi not configuring.
It give me " Failure of key exchange and association"
I’m double check every thing but I recive this error again and again.!

Jetson_nano_2gb_setup_error|661x419

If I pass this step, after the finishing setup I can’t edit /etc/wpa_supplicant.conf file because of permission restrictions. When I try to change this file permission using chmod It’s need root password. Configurator not ask me set the root password.

how can I fix this problem?

Hi, Pls try with the followed command.

sudo nmcli dev wifi rescan # to scan 
sudo nmcli dev wifi # to show wifi hotspots
sudo nmcli device wifi connect SSID password PASSWORD #  to connect

Hi;
Thanks for your help. But my Nano 2Gb still not connect my xDSL router’s WiFi network.

nano2Gb_wifi_error

I was double check my router’s security settings (mac filter, mac authen etc.) everything is ok but still not connect.

My WPA2/PSK password is 26 char long is the be problem? Should I try another Wifi dongle ?

I solved this problem. I’m sharing the solution in case someone encounter the same problem.

N='SSID'       #Your Wi-fi's SSID 
P='WPA/PSKPassword'   #Your Wi-fi's WPA/PSK Password 
D=$(LENG=C nmcli -t d | awk -F: '/wifi/{print $1}' | head -1)
(nmcli -f NAME -t c | grep -q "^$N") && nmcli con del "$N"

sudo systemctl restart NetworkManager

sudo nmcli con add con-name "$N" ifname "$D" type wifi autoconnect yes ssid "$N"

sudo nmcli con modify "$N" wifi-sec.key-mgmt wpa-psk
sudo nmcli con modify "$N" wifi-sec.psk "$P"
sudo nmcli connection up "$N"

connection check

nmcli d

DEVICE  TYPE      STATE        CONNECTION
wlan0   wifi      connected    SSID
l4tbr0  bridge    connected    l4tbr0
eth0    ethernet  unavailable  --

The solution for me was to select the option to manually enter my network SSID in the setup dialog. When I entered the network name manually, rather than selecting it from the list, the connection was successful. It may have just been a fluke, but it might be worth a try if you’re facing this issue.

1 Like