Jetson Nano 4 GB Power Supply Major Issue

when I power up the 4 GB Jetson Nano using Barrel Jack Power adapter (5V 4 A), it works fine, but if the power get disconnected (from the source) and come back, the Nano doesn’t power up automatically unless I unplug and plug back the barrel jack again.

So, even if I have the barrel jack power is connected to the Nano, and I plug the adapter to the wall, it will not work, unless the Barrel Jack power physically unplugged and plugged back in.

Seem to be similar issue here: Power Supply Problem - #2 by Trumany

Any thoughts?

How long have you waited before plug back again? Jetson board needs time to discharge and then can be auto-power-on.

@Trumany I waited for 5 minutes, and all the way to one hour as well at a different trial.

the 2 GB go back right away, for the application I am using 4 GB for, I cannot wait for more than 2 minutes.

This seems the adapter has some left power, can you try another adapter or DC supply? Or can you measure the voltage of barrel jack to check the voltage level difference b/w your two operations?

I found power adapters types from Amazon that has 5V and 4A that solved the issues, unfortunately I wasn’t allowed to paste the link.

Do you mean you had solved this issue with another power adapter?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.