Jetson Nano 4gb shutdown after running Deepstream


I had raised the above issue for my Jetson Nano 4gb, but when I try to do the steps for yolov4-tiny , the steps were -

YoloV4 Tiny

Verified environment:

  • JetPack4.5.1 + Xavier

Deepstream can reach 60fps with 4 video stream on Xavier:

$ cd /opt/nvidia/deepstream/deepstream-5.1/sources/objectDetector_Yolo $ wget $ git apply yolov4_tiny.patch $ export CUDA_VER=10.2 $ make -C nvdsinfer_custom_impl_Yolo

$ wget -q --show-progress $ wget -q --show-progress $ wget $ wget

$ deepstream-app -c deepstream_app_config_yoloV4_tiny.txt

When I run the final command the whole Jetson Nano freezes and shut down abruptly, can someone help me to resolve this deepstream issue.


Is it shutdown or restart?
If it’s shutdown, could you share the kernel log from UART terminal?
If it’s reboot, please share the output of below command:
# cat /sys/fs/pstore/console-ramoops-0

Suspect it reboots due to OOM (out of memory).



Its a proper shutdown. How do I check the kernel log from UART terminal? If you could share me the steps to do it would be great.

However I tried to the deepstream one last time before writing this and I got the output for around 30sec-45sec and then it got shutdown completely.

It would be great if you could share the kernel log UART terminal procedure.


refer to Jetson Nano - UART - JetsonHacks


Is there any way to get the UART without using the Adafruit USB to TTL Serial Cable – Debug / Console Cable?
Could you help me with it if any other method is there


You can google search “jetson nano uart”.
I think kernel log is necessary.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.