Jetson Nano and Julia?

Is it possible to implement and run the Julia programming language on a Jetson Nano? Has anyone gained any experience with it?

And because I have a lot of fantasy, is it possible to install JuliaPro on the Nano?

There are Linux versions for both applications, but no reasonable reaction from the Nano. I admit, I also have almost no Linux (Ubuntu) experience…!

I’m glad about every little hint! Thank you!

Hi Student_DE,

We haven’t try Julia on Nano yet, not sure if any specific environment configuration requirement or issue there. You may try and share your finding to forum.

  1. go to https://julialang.org/downloads/
  2. download the Generic Linux Binaries for ARM aarch64
  3. follow platform instructions for Linux: https://julialang.org/downloads/platform.html

Hi dkreutz,
this is what I was trying to do. Unfortunately, as written, I don’t get a reasonable reaction. The Julia symbol shows a kind of “heartbeat” for 5 seconds and then literally nothing more. I would be happy about a message like "Sorry, Julia is not designed for my system …! Then I would have clarity!

Hi kayccc,
thanks for your answer! I’m working my way deeper into Ubuntu to avoid a mishandling by myself. But I think that Julia is not running on the Nano (but would be a great thing if Julia was suitable for the Nano)!

I continue my research and report…!

Hi Student_DE,

I tried it and it works on my Jetson Nano with Jetpack 4.2.1 [L4T 32.2.0]
My download is: https://julialang-s3.julialang.org/bin/linux/aarch64/1.2/julia-1.2.0-linux-aarch64.tar.gz

jetson@jetson-nano:~/julia/julia-1.2.0/bin$ ./julia 
               _
   _       _ _(_)_     |  Documentation: https://docs.julialang.org
  (_)     | (_) (_)    |
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 1.2.0 (2019-08-20)
 _/ |\__'_|_|_|\__'_|  |  Official https://julialang.org/ release
|__/                   |

julia> 6*7
42
1 Like

Hello dkreutz,

thanks for the link! Exactly this link I had already used. I read myself a little deeper into the handling of tar.gz files and installed it without " pressure ". Still a few challenges with the path variable had, but finally I can say “it runs”! :)

Hi kayccc,

from my point of view I can say that Julia is running on the Jetson Nano!

i have use jetson nano 2GB kit. It’s simply install julia 1.5.3.
just remember download linux-Arm version. that’s all. thank you.

1 Like

I am interested in Julia v0 and not v1.
I tried to download on my Jetson Nano the git repository and make it (from GitHub - JuliaLang/julia: The Julia Programming Language).
But i have an architecture problem : “unknown world size for arch aarch64”
Any ideas how to solve that ?