Jetson Nano and ZED Camera

Hello,

I started to study on ZED Camera. I succesfully installed packages and Python API as given in here: https://github.com/stereolabs/zed-python-api

My code has only two rows for importing libraries and these rows are
import pyzed.sl as sl
import cv2

When I want to import “pyzed” in my code named “zed” I have problems as:

On the Jetson Nano terminal, when I run sudo python3 zed.py the pyzed library is not imported. However, when I run python3 zed.py cv2 is not imported.

sudo imports cv2, but not pyzed.

or

python3 imports pyzed but not cv2.

What is the problem? Could you please help me?

Hi,
Please check if you can launch the camera by following steps in FAQ
Q: I have a USB camera. How can I lauch it on Jetson Nano?

Thanks for your reply. I can launch the camera from ZED tools.

But, I want to launch it on a python code. So I need to import cv2 and pyzed together.

I solved the problem.

When you install Python API for ZED Camera there is a step:
To install it run :
python3 -m pip install pyzed-3.1-cp37-cp37m-linux_x86_64.whl

I changed it as

sudo python3 -m pip install pyzed-3.1-cp37-cp37m-linux_x86_64.whl

and it worked. Now I can get images from python script by sudo python3 process.py command on the terminal.

Good to know it is resolved and many thanks for the sharing.

1 Like