Jetson Nano Audio I2S not work

I have a progress. After I run
amixer -c “ape sound card name” cset name=“I2S4 Mux” “MVC1”
amixer -c “ape sound card name” cset name=“MVC1 Mux” “ADMAIF1”
no was sound but after I tried again
amixer -c “ape sound card name” cset name=“I2S4 Mux” “ADMAIF5”
speaker-test -D hw:“ape sound card name”,4 -r 48000 -c 2 -F S16_LE -t sine -f 1000 -l 5
I hear sound of 1KHz !
I tried to play sound test by application “Sound” but it not work and also tried play mp3 file also no effect.

Looks like in standard image not exist drivers :
aplay -D hw:tegrasndt210ref,0 test.wav
aplay: test_wavefile:1014: can’t play WAVE-file format 0x0055 which is not PCM or FLOAT encoded

aplay -D hw:tegrasndt210ref,0 test.mp3
Playing raw data ‘test.mp3’ : Unsigned 8 bit, Rate 8000 Hz, Mono
aplay: set_params:1299: Sample format non available
Available formats:
- S8
- S16_LE
- S24_LE
- S32_LE

Hi chaplin.u
Good to see some progress on your side.

Please note aplay tool is basic ALSA utility which can play only Wavefiles (MP3 is not supported with aplay).

I believe you are trying audio playback on Ubuntu GUI applications. If audio not working, then we need to cross the alsa configuration settings for userspace at target path file " /usr/share/alsa/init/postinit/00-tegra.conf "

Can you cross check it below entry was present on the above file.

CARDINFO{name}==“NVIDIA Jetson Nano APE”,
CTL{name}=“ADMAIF1 Mux”, CTL{value}=“I2S4”
CTL{name}=“I2S4 Mux”, CTL{value}=“ADMAIF1”

If above configs present then playing below command should work after device reboot. No need any extra mixer control. Also audio should work on GUI applications too with above configs.
speaker-test -D hw:“ tegrasndt210ref”,0 -r 48000 -c 2 -F S16_LE -t sine -f 1000 -l 5

in this place

exist 2 files but no card you talk about :
00-tegra.conf (6.0 KB)
01-tegra-rt565x.conf (3.2 KB)

This is the entry which can help for userspace.

CARDINFO{driver}==“tegra-snd-t210r”, \
CTL{name}=“I2S1 Loopback”, CTL{do_search}==“0”, \
CTL{name}=“I2S4 Loopback”, CTL{do_search}==“1”, \
CTL{name}=“ADMAIF1 Mux”, CTL{value}=“I2S4” \
CTL{name}=“I2S4 Mux”, CTL{value}=“ADMAIF1”

Expecting above should work for userspace audio, If not please edit 00-tegra.conf for the above entry and replace below entries

CARDINFO{driver}==“tegra-snd-t210r”, \
CTL{name}=“ADMAIF1 Mux”, CTL{value}=“I2S4” \
CTL{name}=“I2S4 Mux”, CTL{value}=“ADMAIF1”

When I try to play any WAV file
aplay -D hw:tegrasndt210ref,0 test.wav

I receive this message :

I corrected 00-tegra.conf (5.9 KB) ( removed 2 lines as you explained) but GUI

not work
If I did wrong please correct file and provide me.

The error “can’t play WAVE-file format 0x0055 which is not PCM or FLOAT encoded” clearly says something wrong with the test.wav format. For testing please continue using the “speaker-test -D hw:“ape sound card name”,4 -r 48000 -c 2 -F S16_LE -t sine -f 1000 -l 5” which should be sufficient for command line testing.

Can you provide me the output of below commands after rebooting the target.

#amixer -c “tegrasndt210ref” cget name=“I2S4 Mux”

#aplay -L

#alsactl init

WAV file is default sounds I got from Windows Media directory so it must be standard.
I made reset and reboot and send commands but nothing no happened after

Please avoid # before the commands. I put this to reflect shell terminal should not be included while executing the commands

I did again without #

This is
out.txt (5.2 KB)

one issue with your command again, include double quotes to mixer name like below.

amixer -c “tegrasndt210ref” cget name=“I2S4 Mux”

Corrected and received this
amixer.txt (1.2 KB)

Did you dumped this info after reboot as suggested and without executing any commands. Reason is seeing ADMAIF5 is connected to I2S4 Mux which should not be the case

numid=549,iface=MIXER,name=‘I2S4 Mux’
; type=ENUMERATED,access=rw------,values=1,items=53
; Item #0 ‘None’

: values=5

Just for debug purpose, perform below command and try on userspace sound playback.
amixer -c “tegrasndt210ref” cset name=“I2S4 Mux” “ADMAIF1”

Tried it and test is not make sound but userspace sound playback is WORK !!

Ok, this confirms Userspace audio is working. After boot with below command should show mixer value=1 (i.e ADMAIF1). Make sure I2S4 Mux is not set manually after boot and if ALSA conf set properly during boot, it should straightaway work on userspace.

amixer -c “tegrasndt210ref” cget name=“I2S4 Mux”

I made restart ( reboot) and sound is work without additional commands.
Thanks !

You are a very good specialist and I need help in other things.
I created my own board with use of UARTs and GPIOs . I need help to open all this ports in Nano SOM :

and also work with LIRC

Can you provide solutions ?

Hi chaplin,
Am audio expert but just to understand and guide you to right forum. Are you looking to configure these pins as GPIOS OUT or IN?. If so PINMUX configuration should help here.

If above is not the one looking for, then you can raise a separate Jetson forum query to get help on this.

it’s a pity , because question about LIRC was asked in 2014 and still nobody answer…

Ok, Please raise a separate forum query specific to this for tracking.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.