Jetson Nano auto log in account when poweron without need to press enter

Hello, I’m looking to run my Jetson Nano 2GB dev kit to automatic enter to the desktop interface when power up the Jetson. I already disable the password, but still it requires to press enter keyboard to go into the desktop. How do I remove that user selection? I only have 1 user named ‘myjetson’. I’m new to this device and need this feature.

Thanks in advance! :)

When power on, I don’t want it to display here

Instead, I want it to direct open to the desktop page/interface

Appreciate anyones help on this :( me newbies

hello Hqm996,

had you complete system configuration to enable auto-login?
you should also modify the display configuration to disable the lock menu.

Hi JerryChang,

Thank you for helping me.
Yes, I already configure the enable auto login, but still have the lock menu (no password anymore, just need to click enter to login. I only have 1 user). This is using Jetson Nano Dev 2GB. I tried at Jetson Nano Dev Kit (not the 2GB), works perfectly fine. I want it to be the same for Jetson 2GB.
Please advise me how to do that. :(

hello Hqm996,

it’s the display configuration to disable lock menu.
ideally, you can have exactly same behavior since the system configuration doesn’t depends-on board revision.

how you flash the Nano-2GB, are you using the sd-card image?

Hello JerryChang,

It still stuck here even if I changed to ‘Password: Not asked on login’.
May I know where you found the disable lock menu? I couldnt find it on google.

I used this step installation + balena etcher to flash:

hello Hqm996,

could you please re-flash the target with NVIDIA SDK Manager | NVIDIA Developer.
it’ll download the JetPack release to your local host machine, i.e. ~/nvidia/nvidia_sdk/JetPack_<version>_<platform>/Linux_for_Tegra/

there’s tool to creates default user and bypass the oem configuration setup. please enable --autologin options for setting up the system configuration, after that, you may use the to flash the images for confirmation.

Hello JerryChang,

If flash, all the data will be missing right?
I already start working a lot of stuff for detection and would not like to redo all those again.
Is there any other way?

Hi All,

I still need support on this :( I still cannot figure out the solution.
Thanks in advance!

Hi Hqm996,

Actually, you only need set ‘User Settings’ and change the password to ‘Not asked on login’.

If you still stuck on login screen, please add below lines:

$ sudo vim /etc/lightdm/lightdm.conf.d/50-nvidia.conf
Add below two lines:
1 Like

Hi Carolyuu,

Yes, I did the above previously and stuck on the log in menu.
After adding the lines suggested, it works perfectly well! Problem solved!

Thanks JerryChang and Carolyuu for the great support!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.