Jetson nano B01: camera communication problem

Dear support team,
I have 3 jetson nano B01 KITs. Now I have the following problem:
I used this KIT and edited the device tree and kernel and redesigned the mother board to read image data from two ADV7280m ICs. This is a product we have worked well with KITs I bought over 2 years ago.
The first KIT I bought 2 years ago when I plugged in the SD card and then when I booted it, I received the driver video0 and video1 using the command “ls -l /dev”, but I took this SD card and plugged it into the other 2 KITs, they but not receive driver video0 and video1. I have tested the i2c buses of these 2 KITs and they are working fine.
Here are the booting logs of the two cases above.
2. log_not detected device.txt (23.9 KB)
1. log_detected device.txt (19.7 KB)

Could you try to flash the system through flash command and see if it works? It is supported to flash Jetson Nano module with SD card slot through Suggest try this method.

The operating system boots successfully but still does not recognize the device camera. currently, I am using jetpack version 4.2. Can you tell me what is the difference between the B01 version produced more than 2 years ago and the new version produced?

The device is not enabled by default so you would need to port device tree and enable sensor driver. It probably the device tree and driver are not ready. We would suggest contact device vendor for help.

hi DaneLLL,
I reinstalled the OS, didn’t flash my kernel and device tree, then attached the CAMERA to the 2 available CSI ports on the carrier board and they were working fine. So you mean my sensor adv7280 is not enabled on the new board, because it worked on the board I bought more than 2 years ago?

By default we support Raspberry Pi V2 camera on Jetson Nano developer kit. For other sensors, would need to check sensor driver programming guide and modify device tree/driver to enable it.

thank Danelll,
did anyone face this issue or give me some advice in this case? many thanks

hi DaneLLL,
I realized that the problem was when the system booted it didn’t recognize my device tree in the extlinux.conf file. As far as I know when the system boots it will load the device tree from the dtb partition or the FDT entry. If I configure “FDT /boot/dtb/tegra210-p3448-0000-p3449-0000-a02.dtb” in the file extlinux.conf, the system will get a boot loop, and if I don’t configure FDT, the system will load device tree from dtb partition, please explain to me why. How can I update my device tree?

It sounds to be same as the query in Jetson Nano FAQ

Q: Why pinmux setting does not work on some pins?

Please do clean re-flash and try again.

I fixed this problem by reflashing OS using SDK manager then reloading my device tree using FDT entry. My board has recognized the camera driver Video0 and Video1, but there is another problem: with the same memory card when I insert and boot with the KIT bought more than 2 years ago, the fps after I capture and process it achieved 55fps but with the new KIT the fps is only about 30fps, I have set the function to measure the time of the processing functions, the cpu seems to process the functions in opencv much slower than the old KIT. Do you know why this problem?

Is this the problem, the software version run on the old and new jetson nano KIT is different? If so, is there any way I can get the software running on the new KIT to be the same version of the software running on the old KIT. I also had a similar situation where KIT could not boot unless re-flash OS using SDK Manager.

We would suggest re-flash the system while upgrading to later release. It may not work properly if certain partition is in old release and rootfs in SD card in upgraded to later release.

But the kernel and device tree I edited to match jetpack 4.2. When I flash jetpack 4.6 using SDK manager the bootloader is no longer on SD card and when I use the modified kernel and device tree on jetpack 4.6 the system gets bootloop . So is there any way I can re-flash jetpack 4.2 to boot from SD card?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.