Jetson Nano Camera with remote Desktop

Hi,

I’m completely new to Jetson. I try to connect the Raspi Cam Module V2.1 to the Jetson Nano. When I run the

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12' ! nvvidconv flip-method=0 ! 'video/x-raw,width=960, height=616' ! nvvidconv ! nvegltransform ! nveglglessink -e

command from the CSI-Camera github describption I get the error message:

nvbuf_utils: Could not get EGL display connection
Setting pipeline to Paused

Using winsys: x11
Error: Pipeline doesn't want to pause.
Setting pipeline to NULL ...
Freeing pipeline ...

I use the Windows Remote Desktop Connection from my Desktop PC with xrdp on Jetson Nano to connect and I think that’s the problem.

But is it possible to distribute the video signal (and Ubuntu Desktop) via xrdp to remote desktop? I want to use the Nano as control unit on my RC Car and want to see the camera output on my Desktop PC…

Thanks in advance,
Lars

same error here and I am using RDP from a Linux PC to the Nano

Please check below post:
https://devtalk.nvidia.com/default/topic/1049913/jetson-nano/raspberry-pi-v2-camera-not-recognized/post/5331272/#5331272

Hi DaneLLL,

thanks for the reply and sorry that I didn’t wrote it before:

When I connect the Jetson Nano directly to the monitor, the cam module is working fine.

But when I unplug the monitor and connect via xrdp and remote desktop from my Win10 PC I get the error message. I can see the gnome desktop that is different from the Unity like gnome that I see, when I’m directly connected.

When I build the Jetson Nano on my RC car, I can’t use the monitor cable, but I want to see the camera output (in best case, with a rectangle around the identified objects), and I thought it would be a good idea with a wifi stick and the xrdp/remote desktop connection.

Best regards,
Lars

You may try xvimagesink instead of EGL backend for remote display:

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM),width=3820, height=2464, framerate=21/1, format=NV12' ! nvvidconv ! 'video/x-raw,width=960, height=616' ! xvimagesink

Hi Honey_Patouceul,

that’s working! Many thanks to you! :-)

Lars

Hello, I had the same problem at #4 (when I run “./detect-camera multiped” on HDMI is live view is OK but when I run “”./detect-camera multiped" from a remote connexion there is no live view).

My remote connexion : VNC on port 5901

My IP camera from RTSP.

My pipeline (in gstCamera.cpp) is : rtspsrc location=rtsp://xxxxxxxxxxx:xxxxxxxxxxx@192.XXX.XXX.XXX:554//h264Preview_01_main ! rtph264depay ! h264parse ! omxh264dec ! appsink name=mysink";

Can you help me ?

Thanks

Marco