Jetson nano configure CSI issue

We are using dev kit p3450 with single mipi port(j13) and camera ar0234. All works good.
Port j13 connected to CSI 2 but dts configured to serial_a and port-index 0 it is not correct(maybe). But why is not serial_e ( CSI 2 ) that provided by pinmux table for b01 board .

We use our custom board that connects jetson and same camera sensor. We connected sensor to CSI4 D0, D1 and can’t configure dts files for it. We have communication with camera module over i2c and we have /dev/video0. camera_module inits without problem and erros( same as on kit ).

How to configure dts files correct? We can’t find board scheme and pinmux table for a02 to compare with b01 board.

Check the programing guide for the dts configure.

We have dev kit p3450 a02.
And p3448 jetson module.

I readed all documentation about it and all topics. Thats why I ask for help. In all docs is written that if you want to use another CSI ( CSI4 ) you have to change port-index (VI/CSI) - 2 and tegra_sinterface - serial_c provided by your pinmux table and documents.

On dev kit it works without problem, but i confused why in pinmux table you write that CSI 2 is serial_e and index is 4 but on dev kit(p3450) works on serial_a and index 0???

How I decided that we have CSI2 on our dev kit and not CSI0 as in the b01 board scheme, I rang the nodes of the processor with a mipi connector.

“From the pinmux CSI4 is connect to CSI-C for Nano’s design.
The port-index is 2 and serial_c” - Moderator ShaneCCC topic CSI port-index confusion.

And it doesn’t work on our board. On our board works if we connect(HARD) camera on CSI 2 with port-index 0 and serial_a. Why? But this does not work according to our PCB layout, because of this we need CSI 4.

You do not provide board schematics on our dev kit version, "No dlc version for this board " .

I use pack 32.4.4 and sources by 16 octomber 2020. Camera use pwdn and reset by i2c.

What I missed please help.

I think you may confuse by the pinmux csi#,
Please just confirm your sensor connect to witch CSI port in Nano chip to configure the dts.

We use pinmux from pack and by doc all CSI is enabled and configured. sensor connected to CSI4 pins. Module nodes 48 (CSI4_D0_P),46 (CSI4_D0_N),54(CSI4_CLK_P),52 (CSI4_CLKN),60( CSI4_D1_P),58 (CSI4_D1_N). 122 ( CAM1_MCLK ) ,120 (CAM1_PWDN) .

CSI4 is connect to CSIC, so the port-index is 2 and serial_c in dts.

That’s right. I did it. It does not help

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Did you probe the signal to confirm it. Also have enable the debug print in the csi2_fops.c to check the error status.

I just bought b01 module and everything works fine, you ignored some my questions and your help was useless. Thank you nvidia.