[jetson nano] connect console to HDMI

Hey!

I’m trying to get console on my HDMI display, I’m not using any GUI.

I’ve prepared ubuntu bionic rootfs and I’m using those BSP drivers to flash kernel https://developer.nvidia.com/embedded/dlc/r32-2-1_Release_v1.0/Nano-TX1/Tegra210_Linux_R32.2.1_aarch64.tbz2

I’m using such kernel parameters:

tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,0 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1125 core_edp_ma=4000 tegra_fbmem=0x140000@0x92cb6000 root=/dev/mmcblk0p1 rw rootwait console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 rootfstype=ext4

Only way to see console is using UART over ttyS0 or openssh

All we see is nVidia logo, and then black screen, dmesg:

[    0.809578] tegradc tegradc.1: dpd enable lookup fail:-19
[    0.433813] iommu: Adding device tegradc.0 to group 14
[    0.433883] platform tegradc.0: domain=ffffffc0f948aa98 allocates as[0]=ffffffc0f9b54248
[    0.435292] platform tegradc.0: IOVA linear map 0x0000000092cb6000(140000)
[    0.435698] platform tegradc.0: IOVA linear map 0x00000000d7000000(19000000)
[    0.436035] iommu: Adding device tegradc.1 to group 15
[    0.436098] platform tegradc.1: domain=ffffffc0f948acd8 allocates as[0]=ffffffc0f9b542b0
[    0.437528] platform tegradc.1: IOVA linear map 0x0000000092cb6000(140000)
[    0.437937] platform tegradc.1: IOVA linear map 0x00000000d7000000(19000000)
[    0.765682] tegradc tegradc.0: disp0 connected to head0->/host1x/sor1
[    0.766030] tegradc tegradc.0: DT parsed successfully
[    0.766091] tegradc tegradc.0: Display dc.ffffff800ab40000 registered with id=0
[    0.766744] tegradc tegradc.0: Bootloader disp_param detected. Detected mode: 640x480 (on 0x0mm) pclk=25173906
[    0.770088] tegradc tegradc.0: probed
[    3.191994] tegradc tegradc.0: fb registered
[    4.323210] tegradc tegradc.0: DC initialized, skipping tegra_dc_program_mode.
[    4.330469] tegradc tegradc.0: hdmi: tmds rate:25174K prod-setting:prod_c_hdmi_0m_54m
[    4.338641] tegradc tegradc.0: hdmi: get RGB quant from REG programmed by BL.
[    4.345797] tegradc tegradc.0: hdmi: BL set VIC 0
[    4.350511] tegradc tegradc.0: hdmi: get YCC quant from REG programmed by BL.
[    4.380621] tegradc tegradc.1: disp1 connected to head1->/host1x/sor
[    4.387030] tegradc tegradc.1: No lt-data, using default setting
[    4.393060] tegradc tegradc.1: No hpd-gpio in DT
[    4.397694] tegradc tegradc.1: DT parsed successfully
[    4.402763] tegradc tegradc.1: Display dc.ffffff800d4c0000 registered with id=1
[    4.410764] tegradc tegradc.1: dpd enable lookup fail:-19
[    4.419100] tegradc tegradc.0: nominal-pclk:25174825 parent:25173906 div:1.0 pclk:25173906 24923052~27440532
[    4.420450] tegradc tegradc.1: probed
[    4.432607] tegradc tegradc.1: fb registered
[    4.585320] tegradc tegradc.1: blank - powerdown
[    4.638060] tegradc tegradc.0: blank - powerdown
[    4.693259] tegradc tegradc.0: unblank
[    4.725134] tegradc tegradc.0: nominal-pclk:146250000 parent:146250000 div:1.0 pclk:146250000 144787500~159412500
[    4.725183] tegradc tegradc.0: hdmi: tmds rate:146250K prod-setting:prod_c_hdmi_75m_150m
[    5.184477] tegradc tegradc.0: hdmi: plugged

Any ideas, probably something obvious…

Could you try to use

echo 0 > /sys/class/graphics/fb0/blank and see if anything?

Actually, I think you just need to disable gdm3 to auto-start in each boot up and then you will see the console.

Hey WayneWWW!

I’ve forgot to mention I’ve installed only: ubuntu-minimal,nano,bash,openssh-server so I do not have any gdm3 and GUI software installed on my bionic rootfs.

I’ve tried all I’ve found about debugging display here: https://elinux.org/Jetson_TX2/r28_Display_debug

So including this line:

echo 0 > /sys/class/graphics/fb0/blank

Nothing happens. Still black screen…

PS: See dmesg above:

[    4.693259] tegradc tegradc.0: unblank

So I guess driver is actually doing it.

Hi lpiatek,

Please use official rootfs and just disable the gdm3.
I don’t know how to help you if you are using a custom rootfs.