Jetson Nano Crashes at high clock speeds

I run a jetson nano on nv-jetson-nano-sd-card-image-r32.2.1 and it crashes frequently. I have a PWM/Tacho cooling fan. It’s reproducable when I run jetson_clocks.
I am being told by support chat to post here so a developer can respond.

What kind of power supply are you using? Try using a 5V 4A like this:

In addition to what @leo253 is saying, make sure that it is truly crashing, which is quite different from powering down as power becomes unstable. Jetsons are rather sensitive to power regulation, and running at max clocks draws more power than not at max clock.

If you really want to know, then you probably have to log in via serial console and run “dmesg --follow” to see what shows up during the crash (the terminal runs on the host PC instead of the Jetson). Even in a crash you will still see serial console logging, but power off may just cut abruptly. For serial console info see:

Many thanks for the quick response and kind advice.
Changing to a 5V/4A external power supply resolved the issue. The system run stable for several hours now at high clock speeds.