Jetson Nano crashes when running nvgstcapture-1.0

Hi @dusty_nv,

I used an SD image for my jetson nano, which is now running Jetpack 4.6.1 or L4T 32.7.1. I also downloaded and am running the corresponding docker container here. The container seems to work fine, but when I attempt to use jetson_utils.videoSource(), or anything else using the camera, such as nvgstcapture-1.0 (outside the container), the jetson freezes and then crashes. I have the SainSmart imx219 camera and it does appear to be recognized, because the videoSource will be successfully created with it. The output at the end will say:

gst argus starting repeat capture requests
consumer: producer has connected. continuing
frozen and reboots a few moments later

I have the jetson powered with a 5v 4a barrel jack and I have tried on both 5w and full power mode. I have also tried using the version of jetson-inference without nvmm as suggested by some other post. I do have a rgb keyboard (only external keyboard I have, which I have tried disconnected after starting the program and before it crashes to no effect) and a mouse attached, along with a 3.2in waveshare display (though that has its own power) and the camera.

Can you help me figure out why the jetson is crashing?

Please confirm the sensor functionality by v4l2 command.

v4l2-ctl --stream-mmap -d /dev/video0 

Thx for replying. When running that (not in the container), it sits there and doesn’t terminate. No window appears or anything.

What’s the sensor?

v4l2-ctl --list-formats-ext

The sensor is a SainSmart IMX219 camera.

	Index       : 0
	Type        : Video Capture
	Pixel Format: 'RG10'
	Name        : 10-bit Bayer RGRG/GBGB
		Size: Discrete 3264x2464
			Interval: Discrete 0.048s (21.000 fps)
		Size: Discrete 3264x1848
			Interval: Discrete 0.036s (28.000 fps)
		Size: Discrete 1920x1080
			Interval: Discrete 0.033s (30.000 fps)
		Size: Discrete 1640x1232
			Interval: Discrete 0.033s (30.000 fps)
		Size: Discrete 1280x720
			Interval: Discrete 0.017s (60.000 fps)

How about below command.

v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap

Same thing as before, no output. I ordered a new camera that should arrive later today if you want to check in after I see if that one works.

Update: I ordered the Arducam IMX219 Nano Fixed Focus camera and this worked just fine. Interestingly, the camera’s quickstart had a troubleshooting section with this exact error and said it could either be a faulty connection or a faulty module. Conclusively, if your connection is fine, it is a camera issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.