Jetson Nano - csi working for video-viewer, but not working on detectnet

Issue: When trying to run detectnet csi://0, terminal has an output (gist here), but the video player does not load. Also, after a minute or so my nano seems to brick/gets unusable and I need to unplug it in order for it to function again.

When I run the command video-viewer csi://0, the video streams as expected

I have also run the command video-viewer --input-width=1920 --input-height=1080 csi://0 which runs the video viewer as expected, however when trying the same input type for detectnet, the same issue as above happend (terminal output seems to be the same, but could differ)

Camera Using:
Arducam 12MP IMX477 Automatic IR-Cut Switching HQ Camera for Jetson

Hi @bryan.beshore, the first time you load a model, TensorRT takes a few minutes to run optimizations on the model. This only happens the first time you load each model - after that, the optimized network gets cached to disk.

video-viewer doesn’t load any DNN model, which is why it starts up instantly the first time.

If you let detectnet run, it should eventually start. Or you can try processing it on a static image first too (either way it will take some time on the first run)

Hi @dusty_nv. Amazing. It worked. Thank you so much for the reply (and thanks for being so quick to respond.) I love this Nano