Jetson Nano developer kit does not boot up with getting started instructions and official SD Card image, LED turns on, but nothing on screen


I have received a new Jetson Nano Developer Kit. I tried to get it run following Getting Started with Jetson Nano Developer Kit.
Downloaded Jetson Nano Developer Kit SD Card Image.
Flashed SD image with Etcher.
Inserted SD card in Nano Kit
Plugged in power supply with output 5V-4A to power jack.
Plugged in HDMI, Keyboard, Mouse.
Turned on power.

I could see the LED next to Micro-USB connector turned on.
But there’s no output on display, basically no signal to display.

I even tried supplying power Micro-USB end, same result, LED turned on but nothing on display.

Is there any other setting to be done on developer kit?
Developer kit has part number: 945-13450-0000-100
Carrier board revision is B01.
Model: P3450

Kindly help.
Thanks in advance.

hello akhilesh_moghe,

please refer to to setup serial debug console and gather bootloader logs for reference,

Hello Jerry,
Thanks for your reply.

Here’s the serial debug console logs while booting up the board.
JetsonNano_Booting_Serial_Output.txt (1.8 KB)

Serial console output for quick reference:

[0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-39a9dc3d)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x90cd3
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.216] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.222] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.259] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.265] Non secure mode, and RB not enabled.
[0000.364] Csd NumOfBlocks=123596800
[0000.369] Set High speed to 1
[0000.378] Using GPT Primary to query partitions
[0000.395] Using BFS PT to query partitions
[0000.400] failed to load NvTbootTbootCpu from (4:0)
[0000.404] re-load NvTbootTbootCpu from (2:0)
[0000.410] Invalid GPT Partition
[0000.415] Invalid GPT Partition
[0000.418] Error is 1

hello akhilesh_moghe,

could you please share the release version of the downloaded SD card image?
btw, there’s an alternative way of using NVIDIA SDK Manager | NVIDIA Developer, please also have a try.

Hello Jerry,

I had downloaded the SD card image from:

the downloaded SD card image is:


hello akhilesh_moghe,

may I know is your Jetson Nano ever flashed before?

in order to rule out hardware issue,
could you please enable SDKManager to flash the board, or, please execute flash script at your local JetPack release path to flash the board manually for confirmation.

Hello Jerry,

The board is a new one, not flashed before.

I could flashed the board with flash script, following Quick Start Guide.
The board got flashed successfully, I could complete initial setup on board and can use board in headless mode.
But, there’s no output on HDMI display.
The Keyboard and Mouse are not working.

By following this Quick Start Guide,
is it expected to have any output on HDMI display
Or this quick start guide is only meant to provide terminal access in headless mode?

Thanks & Regards,

please enable SDKManager to flash the board, it’s by default to install ubuntu desktop.

Thanks Jerry for you help on this issue.
I could flash the board successfully with flash script.