Jetson Nano Developer Kit Ethernet Firmware Update

Hi all, we’ve released a utility that will update the Ethernet firmware programmed on Jetson Nano Developer Kits manufacturer prior to 5/15 (week 21 of 2019). The updated firmware corrects the following behaviors with the Ethernet port:

  • Enable the RJ45 activity/link LED's
  • Use the board's unique MAC address

The utility determines whether your system needs it’s firmware updated and applies new firmware only if required.

The week of manufacture can be seen in characters 4-7 of your developer kit’s Serial Number, located on the underside of the board. For example, a Serial Number of xxx1019xxxxxx indicated manufacture in the 10th week of 2019.

External Media

Download Link -

Woohoo! That worked for me w/o need to reboot. Thanks a lot for working on fix for this issue.

Thanks, it’s much nicer seeing the leds work like they’re supposed to.

Hi dusty!

I have tried the update on my Jetson Nano DevKit, but nothing has changed at all.

The serial number looks like xxx1119xxxxxx (indicating that is was manufactured in the 11th week of 2019 - so well within the range of devices affected by the mentioned issues).

The situation before I ran the update was the following:

  • The ethernet activity LED (yellow) was already working, but the link LED (green) was not.
  • "ifconfig eth0" showed a MAC address starting with "00:04:4b".
  • I followed the README file. The updater indicated a successful update (“Patch OK!!!”). I triggered a restart and afterwards even a cold start, but no change occurred at all and the link LED is still off.

    What am I missing here?

    Best regards,

    Hi Mario, does your MAC address now match the one from your S/N sticker located on the underside of your devkit, as shown above?

    Hi dusty!

    The MAC address was already matching the one on the sticker before I ran the update (ifconfig output). I double-checked with the DHCP leases issued by my router and the MAC address did not change after the update.

    Best regards,

    Hi Mario, that coupled with the fact that your activity LED was working, may point to your unit not being affected by these particular issues. The link LED may be unrelated or the local network setup, I am not too sure. If it’s bothersome, you could RMA your unit for another and see if the behavior is fixed on your network.

    Hi dusty!

    No need for RMA. My Nano works fine and I can live with the link LED not working. I was just curious because I thought this update would somehow make the LED work.

    Best regards,

    Hi Mario, since you already had your correct MAC address and link LED, it sounds like you may have a different issue than what the firmware patch addresses, sorry about that.

    Mine is updated but just see the line ‘inet6 fe80::22f4:…’, can’t find inet line as in the README file. The wired connection still failed.

    Verifying the updated firmware:

    1. To verify that the onboard Ethernet firmware has been successfully
      updated after the reboot, enter this command:

      $ ifconfig eth0
      eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
      inet netmask broadcast
      inet6 fe80::dbd:d4f4:55ea:25c4 prefixlen 64 scopeid 0x20
      ether 00:04:4b:e3:f8:40 txqueuelen 1000 (Ethernet)

    Hi cccheng, if your router is in ipv6 mode, it may not assign ipv4 address and you wouldn’t see it listed (unless you disable ipv6 in your Nano networking settings).

    Does the MAC address that is listed reflect the correct one from the S/N sticker found on the underside of your devkit?

    How do you update the firmware on the Jetson Nano using the downloaded file?

    Hi dlauffer, extract the archive and run the included patch application with sudo permissions. Then reboot your Nano for any changes to take effect.

    Instructions are included in the README. The patch application detects the firmware version and automatically applies the firmware update if needed.

    Hi dusty, thank you for the information. I ran the patch updating the firmware. The results were:

    • the MAC address now agrees with the one on the development board (in QR code)
    • the activity LED works, but the link LED does not.

    After updating the firmware, my end result appears to be the same as Mario’s.
    Best regards,

    Hi dusty,
    I follow the instruction and patch OK but the MAC address still not change.
    Is there anything wrong? I have 5 jetson nano here and all of them got the same issue

    Hi dlauffer and,

    Sorry for the late reply, if still got problem, please help to open a new topic for your issue, we will support from there.


    Thanks, I somehow missed this update a while back. Link and Activity LEDs now work on my 11th week of 2019 dev kit.


    I have a dev kit that is manufactured on the 1st week of 2021 and I’m seeing the mac address issue. Is this supposed to happen?

    Hi @nicholas.leong, thanks for letting us know, we will look into it at the factory.

    Are you able to patch it with the utility above?

    Hi @nicholas.leong, can we get your serial number so we can check the factory logs? Thanks.