Jetson Nano Developer Kit not bootup

After loading image on 32 GB sdcard, board not boot up after power on.
Image : jetson-nano-4gb-jp441-sd-card-image.zip
Log for image download

root@00d069-4ef33c:/mnt/emmc#
root@00d069-4ef33c:/mnt/emmc# /usr/bin/unzip -p jetson-nano-4gb-jp441-sd-card-image.zip | sudo /bin/dd of=/dev/sda1 bs=1M status=progress
14384168960 bytes (14 GB, 13 GiB) copied, 759.009 s, 19.0 MB/s
0+202585 records in
0+202585 records out
14400094208 bytes (14 GB, 13 GiB) copied, 776.048 s, 18.6 MB/s
root@00d069-4ef33c:/mnt/emmc# eject /dev/sda1

board not bring and also when connect on HDMI , not showing anything. not getting USB serial console in micro USB.

Able to dump the serial console from uart?

no, we didnt get anything on UART as well HDMI.
We used microUSB cable for UART.

Sorry that I don’t quite understand your point…micro usb is not able to dump the uart log.

We have " Jetson Nano Developer Kit" board and it has only a microUSB connector where we get console. Am i right?

We are following step as per below link “https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit#setup

How about reading the page I just posted first?

I means earlier when it was first time power on, we got console in microUSB port but once reimage card. we didnt get console. Do you need any screen for board.? Let me setup

The micro usb port does not provide uart log. It only provides the kernel log. That is my point.
And that is why I ask you to check the page. It will tell you how to dump the log from uart.

1 Like

Thanks Wayne for Debug UART clarifcation. now I got console debug from baseboard. and I got below error.

I have inserted 32 GB card with image flashed.

I have created sdcard using below command

/usr/bin/unzip -p jetson_nano_devkit_sd_card.zip | sudo /bin/dd of=/dev/sda1 bs=1M status=progress
eject /dev/sda1
------------------- Console---------------------

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2020.12.03 11:05:47 =~=~=~=~=~=~=~=~=~=~=~=
[0000.126] [TegraBoot] (version 00.00.2018.01-l4t-33e7fa82)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.152] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x201ff0
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0, RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.217] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.223] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.256] Platform-DebugCarveout: 0
[0000.260] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.266] Non secure mode, and RB not enabled.
[0000.272] Invalid GPT Partition
[0000.287] Using BFS PT to query partitions
[0000.291] failed to load NvTbootTbootCpu from (2:0)
[0000.296] re-load NvTbootTbootCpu from (4:0)
[0000.430] Csd NumOfBlocks=62333952
[0000.443] Invalid GPT Partition
[0000.633] Using BFS PT to query partitions

Looks like the sdcard image is corrupted.

Just want to confirm… is it a 4gb-nano device or a 2gb-nano?

How can I find nano device?
printed on board as below

let me share screen

Looks like a 4gb device. Have you tried sdkmanager or other sdcard?

I have tried with linux command, May i try with Window sdk manager?

Yes, please try it. BTW, sdkmanager is also on linux host.

Thanks Wayne. Now I am able to successfully boot linux using sdcard.

I have download 6gb image , download balenaEtcher-Setup-1.5.111 and load new sdcard and success.
Now when I access board via putty serial . It ask for login. What is default login user and password?

Hi,

There is no default login user/pwd… I guess you hit another issue.

Our system will ask you to configure your user account on the monitor during your first boot up…

You can also try to use oem-config to configure it.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fflashing.html%23wwpID0E0JB0HA

But in your current case, you need to reflash it again to trigger this mechanism.

I got it now. when firsttime it was booting. power recycle happen , it might be it was issue. Thanks, let me re-flash it and check it. Thanks.

Thanks Wayne, Now I got access of board with login also. Thanks for active support. We appreciate your effort.

root@ubuntu:/home/manish# uname -a
Linux ubuntu 4.9.140-tegra #1 SMP PREEMPT Fri Oct 16 12:32:46 PDT 2020 aarch64 aarch64 aarch64 GNU/Linux
root@ubuntu:/home/manish#
root@ubuntu:/home/manish#

1 Like