Jetson Nano Development B01s dying like flies. 16 dead and counting

We have tried to build some prototype solar-powered camera’s that do some object detection outdoors. As we only had eight weeks we used Jetson Nano B01 Development boards as we thought this would be the quickest way to get something up and running. The prototypes only have to run for 6 weeks. We have never had any problems with a Nano sitting on a desk powered with a lab power supply, but as soon as we started powering the development boards via a buck converter and started interfacing the Nano via GPIO pins, we started having major issues.
To date we have bought 23 Nanos and 16 have stopped booting up. The power led lights up but we don’t see anything on the monitor.
The details of the project:

  • Jetson Nano B01 Development Board booting off 64GB SD card
  • Power supplied by buck convertor converting 12v solar power to 5v that is permanently applied to Nano
  • Nano powered up every day in the morning by an Arduino connecting pins 11 and 12 with a relay
  • Arducam 12MP camera plugged into CSI port 0
  • Noctua NF-A4x10 5V PWM 4-Pin fan as recommended by Nvidia
  • Nano controlling a stepper motor via GPIO pins connected to a stepper motor driver module

So far we have killed Nanos(they will not boot) by doing the following:

  1. Attempting to solder a diode onto backup battery holder for the Real Time Clock(RTC)
  2. Powering up the device from buckconverter
  3. Soldering wires onto power lines
  4. Unplugging camera will running
  5. Plugging in a Real Time Clock module onto some GPIO pins
  6. and various other random events

We have used Raspberry PIs like this before and they have been fine.

Should Nano development boards be used in this way, or should we have used a more production ready system for prototypes?

On a positive note, we could load three object detectors into a Nano concurrently and process 12MP images at a reasonable rate. So the AI edge compute functionality via TensorRT is good if we could keep the devices alive.

Nano devkit is for development in room only, can not be used as a product.

Do you mean some of the modules can not boot up in any situation? If so, it shows the modules may have been damaged, you can run RMA process for them then.

We haven’t designed a product out of the Nano. We tried to build 16 camera’s for a science experiment that is to last 5-6 weeks. The complexity and interfacing in our project is probably no more complex than this project:

Should the Nano never leave the desk?

Do you mean some modules can not boot up even with your original lab power supply? If so, they may have been damaged, you can run RMA for them to find out root cause.

Yes, some of them died while being powered by the lab power supply. I have tried to instigate a RMA, but the Nvidia support person I chatted too said that we could not do that via Nvidia because we didn’t purchase the Nano’s directly from Nvidia. They recommended that we send them back to the suppliers here in New Zealand. Can we still do the RMA process via a third party supplier?

Please follow advice of support team.