Jetson Nano DIN from TDM (TLV320ADC5140)

I have setup the TLV320ADC5140 with SPI to send:

4 channels
single ended

On the Nano I ran:

alsactl init tegrasndt210ref
amixer -c tegrasndt210ref sset ‘ADMAIF1 Mux’ I2S4
amixer -c tegrasndt210ref sset ‘I2S4 codec frame mode’ dsp-b

Then I tried to capture audio with:

arecord -D hw:tegrasndt210ref,0 -r 48000 -f S32_LE -c 4 -d 10 test.wav

The ADC is DC coupled and the HPF is turned off. I used audacity to look at the output of the waveform and see this:

I changed the input DC level but nothing changes. Does “arecord” just record only what comes out of the ADC? Or does it provide some sort of envelope at the beginning?

I verified with a scope that I see DIN signals coming in but I am not able to decode the stream on my scope (don’t have that option) to see what the TDM results are.

Is there anything I am missing doing? I also checked the ports to see how they were configured:

Bank: 1 Reg: 0x70003144 Val: 0x00000044 → dap4_fs_pj4
Bank: 1 Reg: 0x70003148 Val: 0x00000044 → dap4_din_pj5
Bank: 1 Reg: 0x7000314c Val: 0x00000004 → dap4_dout_pj6
Bank: 1 Reg: 0x70003150 Val: 0x00000044 → dap4_sclk_pj7

Which look correct as well.

Okay, I have verified that DIN is working. If I turn off the soft stepping, then the signal just steps right to -1.0 so the problem has to be into the ADC instead.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.