Jetson nano disable uart on ttyTHS2

Hi erveryone,

I want disalbed uart on ttyTHS2, when i delete below files:

  • Linux_for_Tegra/rootfs/etc/systemd/system/nvgetty.service
  • Linux_for_Tegra/rootfs/etc/systemd/system/
    and also delete them from Linux_for_Tegra/nv_tegra/config.tbz2 .

however,after i do, they’re in the same position again.

so,what should I do?


You’ll find an interesting related post about using QEMU on a Linux host here:

The normal method of doing this is on a running Jetson with:
sudo systemctl disable nvgetty.service

What you would do is create the “rootfs/” content as normal, along with (which incidentally uses QEMU these days), and after this is done run the above command. This would be compatible with the package system, and if there are package updates, the configuration should remain honored across updates.

yes, i know that i can use Qemu enter the rootfs, and use the command to disable nvgetty.service. but i want to confirm one point:after i do, do I need to execute the above order again?i want disable it on first boot.

FYI @linuxdev , systemctl also has a --root=... option to specify a rootfs to enable/disable services if that’s all that’s needed.

@tek.xing: “” is used only once. You’d run the commands for disable of nvgetty.service after that run of “”. After that flash will not run “” again unless you do so yourself, and I’m not sure it would apply twice for the package-based releases (earlier releases just copied files and did not use packages). It would not hurt to run the removal steps for nvgetty.service, but once after should be sufficient.

@mdegans: Nice to know…I haven’t used QEMU much for such things, but if one can use the local systemctl without bothering with QEMU, then it simplifies life.